Page 1 of 1

79 GL1 Plugs

Posted: Sun Jul 31, 2011 1:11 pm
by tommydog
The plugs that was n the bike i jus bought I went 2 a parts store 2 get another set told her what it was she said it was 4 a Kawasaki what plug & gap do i need ty

Re: 79 GL1 Plugs

Posted: Mon Aug 01, 2011 1:50 pm
by dingdong
The plugs are NGK D8EA and the gap is .024 to .028. Lots of Japanese bikes use the same spark plug.

Re: 79 GL1 Plugs

Posted: Mon Aug 01, 2011 9:23 pm
by tommydog
dingdong wrote:The plugs are NGK D8EA and the gap is .024 to .028. Lots of Japanese bikes use the same spark plug.
NGK 2120 thats the same plug correct ? & ty again

Re: 79 GL1 Plugs

Posted: Thu Aug 04, 2011 8:16 am
by dingdong
Yes they are the same.

Re: 79 GL1 Plugs

Posted: Thu Aug 04, 2011 8:53 pm
by Fred Camper
Good link here regarding plugs from Randakk's;
http://www.randakks.com/TechTip10.htm

Re: 79 GL1 Plugs

Posted: Sat Aug 27, 2011 11:57 am
by tommydog
I been ridein the bike this mornin its still spittin a lil but it runs good & idles good as usual i have found a few other problems but it is runnin & i ty all 4 the help

Re: 79 GL1 Plugs

Posted: Sat Aug 27, 2011 1:36 pm
by Fred Camper
Sounds like you should balance the carbs next.

Re: 79 GL1 Plugs

Posted: Sat Aug 27, 2011 5:26 pm
by tommydog
Fred Camper wrote:Sounds like you should balance the carbs next.

Yea 1 side is doin the spitin im gonna change the plugs 1st cause they been n there through the 2nd time i put the carb on & started it a few times idk if that will help but there is what im gonna do & tyvm. The speedometer is not workin either & its hard as ever 2 get n 2 neutral ??? ty again