Page 1 of 1

PLEASE HELP!!

Posted: Thu Mar 22, 2012 1:12 pm
by 1983Wang
Alright so I bought a 1983 GL1100 Interstate about a month ago that had sat for a year, from an older gentleman. I got it purring but the rear master cylinder was siezed, after looking over the whole bike I (through use of the do-it-yourself posts) rebuilt ALL the calipers, as well as the front and rear master. Heres were the problems start..... the front master will not flow with the first rubber suction-cup looking thing in it... when its not in there it flows just fine but wont build enough pressure to get a good lever.... the second problem is the rear master.... I took everything apart cleaned it throughly and put the recomended rebuild kit in it.... and now it leaks... bad... I have re-done both the front and back 5+ times each and come to the same result each time. Before I trailer this thing to a mechanic and pay more for the brakes than I did for the bike, can anyone give me any ideas?

Thanks,

Charlie.

Re: PLEASE HELP!!

Posted: Thu Mar 22, 2012 3:53 pm
by virgilmobile
I would venture to guess that on the front,the piston is not being pushed all the way back to the "C" clip.And the rear,either the bore is scarred or the seal in the center of the piston is on backward.
Look at the how to forum for details on reassembly.Many times I just get something pictured in my head just to find out that I've convinced myself that I'm right.

Re: PLEASE HELP!!

Posted: Thu Mar 22, 2012 9:47 pm
by seabee_
I was thinking the out of place rubber too. By all means, check the components first before letting the shop look at it. I've had those oh, darn, moments before. Hope you get it figured out.