Oil leaking from water pump weep hole


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
User avatar
tarheel-cowboy
Posts: 5
Joined: Fri Mar 08, 2013 7:22 pm
Location: Raleigh, North Carolina
Motorcycle: 1981 GL1100 Interstate

Oil leaking from water pump weep hole

Postby tarheel-cowboy » Sat Mar 09, 2013 2:20 pm



Hello again,

Back with another stupid question.
Why would oil be dripping from the water pump weep hole? And what do I do the fix it? Water is not mixing with the oil, also I'm not finding any oil in the coolent.

Cowboy



User avatar
trashtruck
Posts: 236
Joined: Fri Aug 31, 2012 7:55 pm
Location: albany, New York
Motorcycle: 1982 gl1100 interstate

Re: Oil leaking from water pump weep hole

Postby trashtruck » Sat Mar 09, 2013 2:34 pm

water pump has seals on both the coolant side and oil side of the pump. i understand that the pump is repairable but is much easier to just replace it. it's very easy to pinch/roll an o ring during install so be carefull. if you're going to replace it go with oem, not the cheap aftermarket pumps that are known to fail within 6 months.
WHAT IS THE SPEED OF DARK?

User avatar
RBGERSON
Posts: 2612
Joined: Tue Mar 09, 2010 7:57 am
Location: SCOTTSDALE, AZ
Motorcycle: 98 SE GL 1500
had every year from 75 to 83

Re: Oil leaking from water pump weep hole

Postby RBGERSON » Sat Mar 09, 2013 3:36 pm

Several ways oil can leak there. Green is oil. Most common is the oil seal on the end of the pump shaft wears because the pump bearings are going out and it wiggles
Attachments
HAD LOTS OF GOLDWING 75-83
NOW INTO 1500'S..RIDING A 1998 SE

FAIR WINDS,
RB

User avatar
tarheel-cowboy
Posts: 5
Joined: Fri Mar 08, 2013 7:22 pm
Location: Raleigh, North Carolina
Motorcycle: 1981 GL1100 Interstate

Re: Oil leaking from water pump weep hole

Postby tarheel-cowboy » Sat Mar 09, 2013 4:16 pm

Thanks again!!!!!!! I am so glad I found this site.
You guys are the best. Thank you for the help.

I thought that was the problem, but before I tore it down I wanted to make sure.

Thanks again
Cowboy




Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: No registered users and 1 guest