1983 Aspy Dash light not working


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
User avatar
jhbates2000
Posts: 110
Joined: Mon Jan 07, 2013 12:59 am
Location: terre haute,indiana
Motorcycle: 1983 GL1100A Aspencade

1983 Aspy Dash light not working

Postby jhbates2000 » Tue Aug 20, 2013 12:26 am



Up until now the volt meter and the outside temp guage has not worked on my 83 apsy. When I got on the bike after work yesterday morning they started working and have been working fine since. Tonight when I got on the bike to come to work the dash light did not come on. The accessory light for the radio is working though. I am not sure if the dash light has its own fuse or if maybe the light just burned out. Can anyone give me a heads up on this.



User avatar
virgilmobile
Posts: 7647
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: 1983 Aspy Dash light not working

Postby virgilmobile » Tue Aug 20, 2013 9:39 am

The very first thing I'd lay hands on is the faring plug.
All the equipment in the faring gets it's voltage through this plug.
It's located at the lower left inside of the faring...
Turn on the bike,get a good grip and twist,push and wiggle it....
Mine had a few corroded connections that killed some of the electric in the front...It is repairable.

User avatar
tplumlee
Posts: 8
Joined: Sun Jan 08, 2012 9:50 am
Location: Edwards, MO
Motorcycle: 1983 GL1100 Aspencade

Re: 1983 Aspy Dash light not working

Postby tplumlee » Wed Aug 21, 2013 2:45 pm

Is the tail light still working or is it dead too?
1983 Aspencade

User avatar
jhbates2000
Posts: 110
Joined: Mon Jan 07, 2013 12:59 am
Location: terre haute,indiana
Motorcycle: 1983 GL1100A Aspencade

Re: 1983 Aspy Dash light not working

Postby jhbates2000 » Wed Aug 21, 2013 2:52 pm

Works fine...I just thought maybe the bulb burnt out...can't figure out how to take it apart to see

User avatar
jhbates2000
Posts: 110
Joined: Mon Jan 07, 2013 12:59 am
Location: terre haute,indiana
Motorcycle: 1983 GL1100A Aspencade

Re: 1983 Aspy Dash light not working

Postby jhbates2000 » Thu Aug 22, 2013 7:14 am

Well this morning I sit corrected...the tail light was out also...it seems that I wasnt getting a good connection where the fuse goes into the fuse block...so I think today I am gonne clean all the contacts with a small wire brush so this stupid stuff will stop happening

User avatar
tplumlee
Posts: 8
Joined: Sun Jan 08, 2012 9:50 am
Location: Edwards, MO
Motorcycle: 1983 GL1100 Aspencade

Re: 1983 Aspy Dash light not working

Postby tplumlee » Thu Aug 22, 2013 8:28 am

Good deal, hopefully you don't have near the mess I have with mine. The PO really made a mess of the wiring when he put all the extra lighting on my bike.


1983 Aspencade


Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: Google [Bot] and 2 guests