Front brake light switch works no power to bulb


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
traversewife
Posts: 19
Joined: Tue Apr 15, 2014 6:02 am
Location: Paradise, Newfoundland and Labrador, Canada
Motorcycle: 1983 gl1100 interstate

Front brake light switch works no power to bulb

Postby traversewife » Wed Apr 30, 2014 8:11 am



I have read a lot of post on this but can't find the solution, The front brake light switch is working there is power to it but the brake light dose not light up.
The rear brake lights up just fine. The bike is a 1983 GL1100
Help



User avatar
redbug
Posts: 256
Joined: Fri Sep 30, 2011 8:22 am
Location: Broken Arrow,Ok
Motorcycle: 1983 Gl1100I
1986 Harley FLHT

Re: Front brake light switch works no power to bulb

Postby redbug » Wed Apr 30, 2014 9:06 am

Have you tried unplugging the wires from the switch and touching them together to see if the bulb lights then?
" Ridin on Tulsa Time "

traversewife
Posts: 19
Joined: Tue Apr 15, 2014 6:02 am
Location: Paradise, Newfoundland and Labrador, Canada
Motorcycle: 1983 gl1100 interstate

Re: Front brake light switch works no power to bulb

Postby traversewife » Wed Apr 30, 2014 11:18 am

Did as you said and the brake light worked, I am puzzled because if you check for continuity at the switch it's there and works ok but hook it up and it doesn't.
Guess I will need a new one.
Thanks Len

User avatar
virgilmobile
Posts: 7660
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: Front brake light switch works no power to bulb

Postby virgilmobile » Wed Apr 30, 2014 11:37 am

It's not uncommon for a switch to show continuity until there is a load applied and current has to flow through the corroded contacts...
Always test switches under operating conditions...corrosion can pass enough electric to operate a ohm meter but fail when you attach a 5 amp load to it.
The switch can be replaced or if your really good with tiny springs and levers,the contacts can be cleaned...

traversewife
Posts: 19
Joined: Tue Apr 15, 2014 6:02 am
Location: Paradise, Newfoundland and Labrador, Canada
Motorcycle: 1983 gl1100 interstate

Re: Front brake light switch works no power to bulb

Postby traversewife » Wed Apr 30, 2014 7:17 pm

Thank you Virgilmobile, did what you said, opened the switch by drilling the plastic welds ,cleaned the contact points with a cardboard nail file and Da Da everything fine again. I resealed with a very small amount of silicone around the outside and put it back in place works great.
A note to anyone that might want to try this...Don't disassemble the switch just clean the contacts and put the cover back on.A small vice to hold it will help too.
Len




Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: No registered users and 2 guests