speedometer/odometer


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
wandering_man
Posts: 12
Joined: Tue Mar 26, 2013 12:34 am
Location: Kamloops B.C. Canada
Motorcycle: 1982 1100 GL Interstate

speedometer/odometer

Postby wandering_man » Wed Oct 01, 2014 9:08 am



Just finished changing front breaks, rotors and rebuilding calipers on my 92 1100i. Great pictures from this site. My problem is now the speedometer works fine but the odometer and trip meter don't work. They did work before. Any ideas what I might be able to do to fix this problem?



User avatar
virgilmobile
Posts: 7659
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: speedometer/odometer

Postby virgilmobile » Wed Oct 01, 2014 10:39 am

I've had a 81 mechanical spedo apart...the ODO is worm gear driven directly from the spindle where the spedo cable attaches.
If the spedo works..so should the ODO..unless the plastic gear is broken...Mine was cracked and slipping on the shaft...No..even I could not glue it together.
The only way to even "look see" is to cut or pry the chrome ring off...Forget about removing the reset knob too...broke mine clean off...
It ends up messy looking trying to get it back on again..dented ring and all....
I tried once...it ended up in the trash can and I replaced it with another..It was cheaper than sending it to a repair service....

Come to think of it...My 96 Ford Explorer ODO quit too....almost 2 years ago....Same problem...With 178k miles showing....Oh well...


Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: MSNbot Media [Bot], RBGERSON, Yahoo Slurp [Bot] and 2 guests