1980 rear brake wont build pressure or drain fluid


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
User avatar
tallman21
Posts: 227
Joined: Tue Feb 15, 2011 8:09 pm
Location: Rahway, New Jersey
Motorcycle: 1980 GL1100i

1980 rear brake wont build pressure or drain fluid

Postby tallman21 » Tue Nov 11, 2014 6:39 pm



Hey guys. So a week ago i noticed my rear brake started losing pressure and I had to pump it a bit to build back up. Now no matter what I do it wont build pressure. I bought a vacuum kit and i cant really suck any fluid out of the bleeder port even when pumping the break. I tried disconnecting the brake line from the rear master cylinder and i was able to suck air through.

Could it be my master cylinder is clogged? or not working. I cant figure it out and it is frustrating. Especially since it is my only mode of transportation.

Thanks!

Eric



User avatar
WingAdmin
Site Admin
Posts: 17046
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: 1980 rear brake wont build pressure or drain fluid

Postby WingAdmin » Tue Nov 11, 2014 11:04 pm

That sounds like a master cylinder rebuild is in your immediate future.

User avatar
tallman21
Posts: 227
Joined: Tue Feb 15, 2011 8:09 pm
Location: Rahway, New Jersey
Motorcycle: 1980 GL1100i

Re: 1980 rear brake wont build pressure or drain fluid

Postby tallman21 » Wed Nov 12, 2014 4:16 am

sounds like its time to head over to the DIY section. Thanks WingAdmin!


Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: No registered users and 3 guests