Sound, Digital Readout (radio) and Turn Signal - GL1100


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
Post Reply
CoffeeNinja
Posts: 2
Joined: Fri May 04, 2018 1:57 am
Location: Piteå, Sweden
Motorcycle: 1983 GL1100A Aspencade

Sound, Digital Readout (radio) and Turn Signal - GL1100

Post by CoffeeNinja » Fri May 04, 2018 2:21 am



Hey everyone!
I am a newbie here and a first time (happy) Goldwing owner. 1983 GL1100A Aspencade.
I purchased the bike in November in Stockholm, and drove it up to Northern Sweden where I live.
It sat in the garage where I have been polishing it and cleaning it up ever since.
I took her out for her first real test ride on May 1st. Everything ran great after warming up. All digital readouts on the fairing were working, all lights coming on, and the radio was blasting.
Got her home and parked her in the garage. Later on in the evening I started cleaning her off and decided to clean the vinyl and rubber a bit (seat, switches, fairing, etc).
Two days later I go in to continue waxing, and notice that the digital FM/AM readout tunes up and down, but there's no sound from the speakers. I turn it off, poke around some wires to make sure nothing is loose, and then notice that the FM/AM readout is no longer coming in.
I get suspicious and check the turn signals, and notice that they are no longer turning on and blinking either.
And now this is where I am.
I started going through the fuses (behind the left indicator). 3 white clamshell and 3 "twisty" spring-loaded ones. Only one fuse looked suspicious (but you never know). I tried swapping that fuse with another in there that looked better, but noticed no difference.

So I suppose my question to you experienced owners is this:

Are all these things related electrically?
  • -Radio
    -LED Radio readout
    -Turn Signals
Could it be a main fuse and not an in-line?
When should I think about replacing the flashing indicator relay?

Also, it is worthwhile to note, that the turn signals had actually done something like this before when a mechanic friend and I were taking a look at the bike the first time. He wiggled some wires and then they starting working fine. Could it be the ground in this case?
I appreciate your help and I will provide photos of the wiring (which is quite impressive) and some more insight.
I am going to go and buy a multimeter and some backup fuses today and start testing the old fuses properly.

TLDR: Electrical gremlins started with the speaker sound, then the LED FM/AM readout, and then the turn signals all not coming on. This happened after a short ride and some cleaning.






DaveO430
Posts: 613
Joined: Fri Jan 02, 2015 7:28 pm
Location: Amity. Ar
Motorcycle: 2010 GL1800
2004 Suzuki DR200

Re: Sound, Digital Readout (radio) and Turn Signal - GL1100

Post by DaveO430 » Fri May 04, 2018 6:25 am

Check the glass fuses and their contacts in the fuse box under the faux tank lid and the connector on the left inside of the fairing.

CoffeeNinja
Posts: 2
Joined: Fri May 04, 2018 1:57 am
Location: Piteå, Sweden
Motorcycle: 1983 GL1100A Aspencade

Re: Sound, Digital Readout (radio) and Turn Signal - GL1100

Post by CoffeeNinja » Fri May 04, 2018 9:26 am

UPDATE:
After thoroughly checking the grounds and going through all the glass fuses I could find, I decided to replace the Flasher Relay.
The turn signals are now fully functioning!

Now it is a matter of only the Radio and Radio Indicator not powering up.

It is worth mentioning that the volt meter and the temperature gauge are working absolutely fine. From what I have read, it is often that the Radio Indicator and the Volt Meter go out together.

Post Reply