Speedo whinning noise


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
bcnv1100
Posts: 47
Joined: Tue Mar 29, 2011 5:34 pm
Location: Boulder City NV
Motorcycle: 1981 1100 Goldwing

Speedo whinning noise

Postby bcnv1100 » Tue May 31, 2011 7:59 am



My speedometer needle started jumping a little on the way to work today. It was fine moste the way then started jumping then was fine again. In the parking lot I noticed at the speedometer a whinning noise. The tach had done the same thing a while back, I took it off lubed the cable and put it back. Maybe the same with the speedo??? Anybody know if i can take it apart like the tach cable maybe it needs lubed?? 81, Gl1100



User avatar
bcassel
Posts: 90
Joined: Sat Sep 25, 2010 10:57 pm
Location: Woodland, CA
Motorcycle: 1982 GL1100 Interstate. Originally Candywine color, now Chrysler Cool Vanilla.

Re: Speedo whinning noise

Postby bcassel » Tue May 31, 2011 10:51 am

Yes, you can lube the cable, but it soundsl like the speedo needs lube. I removed the cable connection, attached a 3/8" hose to the connection, held the hose up about a foot or two above the speedo and filled the hose with light oil. Let it sit for a couple of hours, then drained it out and re-attached the cable. Been 3,000 miles now, no whine!

DragonRider
Posts: 136
Joined: Thu May 19, 2011 11:11 am
Location: Ocala, FL
Motorcycle: 1982 and 1983 GL1100 Aspencades

Re: Speedo whinning noise

Postby DragonRider » Tue May 31, 2011 2:44 pm

My wifes bike had same problem, I lubed it and all was good. But here in Florida heat and sun took its toll and now I am looking for a replacement speedo

bcnv1100
Posts: 47
Joined: Tue Mar 29, 2011 5:34 pm
Location: Boulder City NV
Motorcycle: 1981 1100 Goldwing

Re: Speedo whinning noise

Postby bcnv1100 » Tue May 31, 2011 3:28 pm

Does the cable come in/out of the speedo without throwing off the calibration....just pull out and plug back in like the tach cable. Once i take off the cable could i just shoot some cable lube from the spray can into the speedo?? or better to pour a little then drain. Thanks All!!!

User avatar
tallman21
Posts: 227
Joined: Tue Feb 15, 2011 8:09 pm
Location: Rahway, New Jersey
Motorcycle: 1980 GL1100i

Re: Speedo whinning noise

Postby tallman21 » Tue May 31, 2011 5:48 pm

I know that if you take the cable out of the speedo it wont bother it any. I have done it a few times. My speedo cable keeps making a weird vibrating sound but i associated taht with the cable itself not being quite long enough. just had to make it alittle longer :)




Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: MSNbot Media [Bot] and 2 guests