Clarion I radio..display and FM not working well


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
fireguy
Posts: 22
Joined: Wed Sep 30, 2009 10:30 pm
Location: Brantford, Ontario
Motorcycle: 1982 GL1100 Interstate

Clarion I radio..display and FM not working well

Postby fireguy » Sun Dec 13, 2009 12:43 pm



I need help! I have another fairing, and had a Clarion type 1 radio in it. Radio seems to work well...at least it did. The last to didgits on the display don't work all the time, and this seems to be a poor connection somewhere cause if I press on the radio it will start to work. FM worked great but AM didn't....now its the other way around. Antenna is new , but a cheap one. Could I have a bad antenna ground? I need help cause i know absolutely nothing about electronics. Left speaker is weak and crackley too.



User avatar
WingAdmin
Site Admin
Posts: 17050
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Clarion I radio..display and FM not working well

Postby WingAdmin » Mon Dec 14, 2009 11:08 am

The first thing I would do is pull the radio out and clean all of the connectors, using copious amounts of electronics contact cleaner - NOT WD-40. I'd be surprised if that doesn't fix it, but if it doesn't, you might want to contact the people at Sierra Electronics who are pretty well the only people I know of who still fix Goldwing Clarion radios.

fireguy
Posts: 22
Joined: Wed Sep 30, 2009 10:30 pm
Location: Brantford, Ontario
Motorcycle: 1982 GL1100 Interstate

Re: Clarion I radio..display and FM not working well

Postby fireguy » Fri Jan 29, 2010 9:12 pm

I have tried to clean the pin contacts (with contact cleaner) twice. It seemed to help for a little while, then back to the same thing. Contacts of the control knob, especially the am/fm selector seems to be not making good contact either. I noticed some screws on the back. My question is....if i remove the screws and open the back, would this allow me to spray contact cleaner directly onto the potentiometers to clean the contacts?

All the wiring I installed is clean and with good connections. Ground is good and clean as well.

Foam gasket around pins has deteriorated so i will have to figure out a fix for that.

fireguy
Posts: 22
Joined: Wed Sep 30, 2009 10:30 pm
Location: Brantford, Ontario
Motorcycle: 1982 GL1100 Interstate

Re: Clarion I radio..display and FM not working well

Postby fireguy » Sat Mar 06, 2010 12:21 pm

Took the back off the radio....cleaned all the pots and contacts...re-gasketed the back ...made a new gasket from silicone for the gasket around the pins, and voila!....went back in like a charm and cured!

Now all I have to do is find out why the left speaker is weak.

Thanks Wing Admin!

User avatar
WingAdmin
Site Admin
Posts: 17050
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Clarion I radio..display and FM not working well

Postby WingAdmin » Sat Mar 06, 2010 4:17 pm

Try reversing the wiring for the left and right speakers. Connect the left wires to the right speaker, and vice versa. You'll have to use some spare wire to do this, but it's only temporary, for a test.

If you reverse it, and now the right speaker is weak, then the problem is with the wiring, or the amplifier in the radio (or more contacts somewhere). If when you reverse it the left speaker is still weak, then the problem is with the speaker.

fireguy
Posts: 22
Joined: Wed Sep 30, 2009 10:30 pm
Location: Brantford, Ontario
Motorcycle: 1982 GL1100 Interstate

Re: Clarion I radio..display and FM not working well

Postby fireguy » Sun Mar 07, 2010 7:29 am

Great idea ...wish i had thought of it! Should be easy to do, cause i didn't bury the wiring its just behind the signal light.

Thanks




Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: Yahoo Slurp [Bot] and 1 guest