Bad ground on front brake switch?


Information and questions on GL1100 Goldwings (1980-1983)
  • Sponsored Links
red dog
Posts: 27
Joined: Sun Oct 18, 2009 12:01 pm
Location: sanford,fl.
Motorcycle: 1982 gl1100

Bad ground on front brake switch?

Postby red dog » Tue Dec 20, 2011 8:08 am



I've replaced the front brake switch on my 82 GL1100 before and used to check it occasionally after that to find it wasn't working again. I'd take the wires off the switch and clean the area up and it would work. Now it's out again and the switch was tested good. I have power coming to it so I ask if it's the ground wire? The bike only has 64k and all the wires are wrapped lke new. How can I test to see if it's a bad ground?



User avatar
virgilmobile
Posts: 7663
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: Bad ground on front brake switch?

Postby virgilmobile » Tue Dec 20, 2011 8:46 am

Does the foot brake work the light?If it does, the brake light wiring and ground are OK to there.
There's no grounding in the switch,it's just a on/off contact.It can test "good" with no load (ohm meter)and corrosion will stop the electric current flow quick.
Remove the 2 wires from the switch,turn on the key,short the 2 wires together.The brake light should come on.
If not,it's a another problem.If it does the switch is bad.

The switch contacts ,over 25+ years of use will contaminate and/or wear down.
New to you doesn't mean NEW.
I have repaired them but be warned...They have a very small spring in them.The cover can be removed and the contacts scraped carefully to sometimes get it going again.

red dog
Posts: 27
Joined: Sun Oct 18, 2009 12:01 pm
Location: sanford,fl.
Motorcycle: 1982 gl1100

Re: Bad ground on front brake switch?

Postby red dog » Tue Dec 20, 2011 9:13 am

Thanks for the help. I connected the wires and it was a no go. I cut the ground off and stripped the wire back to find corrosion. I cut it back and put on a new connector. Now it works!

User avatar
virgilmobile
Posts: 7663
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: Bad ground on front brake switch?

Postby virgilmobile » Tue Dec 20, 2011 9:31 am

sounds like you have the same problems I have here in Louisiana.....Rust worms got it.
Now you know what to keep an eye on.Good job :D




Return to “GL1100 Information & Questions”




Who is online

Users browsing this forum: Bing [Bot] and 1 guest