Speedometer


Information and questions on GL1200 Goldwings (1984-1987)
  • Sponsored Links
texaskid
Posts: 6
Joined: Fri Jan 24, 2014 11:37 pm
Location: Socorro, New Mexico
Motorcycle: 1985 GL 1200 Interstate

Speedometer

Postby texaskid » Wed Mar 05, 2014 10:51 am



Have a 1985 GL 1200. Speedometer is way off. It says that I am doing about 50 to 55 and actually doing 75. The person I bought it from said that the shop couldn't fix it. Is there some kind of adjustment or does the speedometer need to be replaced or the gear box on the front? Do not have digital. Thanks .



User avatar
virgilmobile
Posts: 7660
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: Speedometer

Postby virgilmobile » Wed Mar 05, 2014 1:45 pm

There are no adjustments.
That far off indicates just a bad spedo,assuming the drive and cable are in great shape.
In the spedo assembly,the cable spins a magnet,it magnetically coupled to the needle assembly which is spring loaded and float on bushings.They do get sticky.
About all that can be done is to "try" to disassemble it,clean the pivot points and add a drop of oil.Clean and lube the drive head too.
Pull the gearbox at the wheel,clean and grease it,inspect,dry lube or replace the spedo cable if the coupler ends are worn badly.
Just spraying WD40 all over it usually just makes a mess.
Meticulous cleaning is needed.
And good luck finding a used one in any better condition.They would be just as old.

User avatar
bassmaster42
Posts: 16
Joined: Tue Mar 11, 2014 8:56 am
Location: somerset,wi
Motorcycle: 1985 gl1200 interstate

Re: Speedometer

Postby bassmaster42 » Tue Mar 11, 2014 9:04 am

so how hard is it to change the gear box for the speedometer . i can turn the cable and the speedometer will move, but when hooked up to the box there is nothing. think i need a new box. or should i just try and clean it out??

User avatar
virgilmobile
Posts: 7660
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: Speedometer

Postby virgilmobile » Tue Mar 11, 2014 2:15 pm

My 83 spedo quit too.I raised the front wheel and disconnected the cable too.
I could spin the cable and the spedo moved...good from there...I rotated the wheel and the coupler did turn the inside fork.
Now what...
.I found that the metal coupler on the end of the cable had moved.When attached to the gearbox,the two ( cable end and drive fork) did not connect.I used a propane torch and warmed the cable end..then pushed it at least 3/8" back up the cable.Reattached and it worke fine.
Sooooo,Lift your wheel and see if the drive is or is not turning with the wheel.
If it does not,remove the wheel and inspect the coupler plate.There are 2 ears that can break/wear.Some can be "tweaked" back into operation.
Post pictures please.

User avatar
bassmaster42
Posts: 16
Joined: Tue Mar 11, 2014 8:56 am
Location: somerset,wi
Motorcycle: 1985 gl1200 interstate

Re: Speedometer

Postby bassmaster42 » Sat Mar 15, 2014 12:38 pm

how to get to the cable that is attached to speeometer. i can see it but cant get a hand on it. it there something i need to take off to get to it easly?

User avatar
bassmaster42
Posts: 16
Joined: Tue Mar 11, 2014 8:56 am
Location: somerset,wi
Motorcycle: 1985 gl1200 interstate

Re: Speedometer

Postby bassmaster42 » Sun Mar 16, 2014 2:35 pm

well getting old one off. but there is no room for your fingers to get new one back in. any suggestions????




Return to “GL1200 Information & Questions”




Who is online

Users browsing this forum: No registered users and 2 guests