Information and questions on GL1200 Goldwings (1984-1987)
  • Sponsored Links
Posts: 27
Joined: Mon May 24, 2010 11:52 pm
Location: St Helens, OR
Motorcycle: 1985 GL1200L Goldwing


Postby rosey1 » Tue May 25, 2010 3:27 pm

I have an 85 LTD that I did a poorboy on and I used as my exciter a white wire that goes into the trip meter. I have since fried the stereo and the dash's speedo tach temp, etc. don't even light up(they're digital), the question I have is did I fry the dash also? I pulled it apart and it doesn't show anything being fried but then again it's microchip controlled so any help would be great. Also are there any in line fuses or such to the digital part? all the lights work on the sides except digital readout so what gives? Bike runs great and charging system was working great too but when I came out the other day the batt was dead(new batt) but quickly recharged and started so I'm also afraid I may have fried alternator. I feel really stupid at this point and am hoping this may be an easy fix...Help? Also I'm new to the forum and I really like the posts and am a owner of an original 75 GL too. Also I posted a message 2 days back and it doesn't seem to be anywhere on the boards? Do they flag or remove posts for odd reasons I'm unaware of?

User avatar
Site Admin
Posts: 16928
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer


Postby WingAdmin » Wed May 26, 2010 1:22 pm

You mean this message?

Check that thread for answers.

Return to “GL1200 Information & Questions”

Who is online

Users browsing this forum: No registered users and 3 guests