Pioneer Radio Problem


Information and questions on GL1200 Goldwings (1984-1987)
  • Sponsored Links
Post Reply
User avatar
Charlie1Horse
Posts: 281
Joined: Mon Sep 16, 2013 9:35 pm
Location: Jacksonville, Florida
Motorcycle: 1986 GL1200A Aspencade
1992 GL1500I Interstate

Pioneer Radio Problem

Post by Charlie1Horse » Sun Sep 14, 2014 4:46 pm



First time posting-here goes. My 86 Aspencade Pioneer radio does not work. The display shows station frequency and will tune up/down but has no sound however it will play a cassette properly. The PO had the radio checked out and said it was good. I have bypassed the AVC and found no change. I replaced the power amplifier with no change. If the cassette works but, no radio volume what could be the problem? If it were the antenna would'nt it have static in the speakers? Any help would be appreciated.
Thanks,
Charlie1Horse



User avatar
WingAdmin
Site Admin
Posts: 17887
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Pioneer Radio Problem

Post by WingAdmin » Mon Sep 15, 2014 3:33 pm

Charlie1Horse wrote:First time posting-here goes. My 86 Aspencade Pioneer radio does not work. The display shows station frequency and will tune up/down but has no sound however it will play a cassette properly. The PO had the radio checked out and said it was good. I have bypassed the AVC and found no change. I replaced the power amplifier with no change. If the cassette works but, no radio volume what could be the problem? If it were the antenna would'nt it have static in the speakers? Any help would be appreciated.
Thanks,
Charlie1Horse
It might not necessarily have static on FM, I would check AM just to be sure. If it's still not giving you anything, I think my next step would be to call Sierra Electronics, they are very familiar with that radio.

Post Reply



Who is online

Users browsing this forum: No registered users and 4 guests