cb stays on channel 1


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
jimgumtow
Posts: 2
Joined: Mon Jul 02, 2012 11:37 pm
Location: pepperell,mass
Motorcycle: 1993 gl1500se

cb stays on channel 1

Postby jimgumtow » Tue Jul 03, 2012 12:11 am



when i turn on my cb, it starts on ch 1, but when i hit the channel "up" or "down" buttons, nothing happens. tx seems to work, although i have yet to setup an intercom/mike in my helmet. any ideas?



User avatar
RBGERSON
Posts: 2625
Joined: Tue Mar 09, 2010 7:57 am
Location: SCOTTSDALE, AZ
Motorcycle: 98 SE GL 1500
had every year from 75 to 83

Re: cb stays on channel 1

Postby RBGERSON » Tue Jul 03, 2012 7:58 am

clean the switch with some spray contact stuff..check the connections inside the switch.
HAD LOTS OF GOLDWING 75-83
NOW INTO 1500'S..RIDING A 1998 SE

FAIR WINDS,
RB

jimgumtow
Posts: 2
Joined: Mon Jul 02, 2012 11:37 pm
Location: pepperell,mass
Motorcycle: 1993 gl1500se

Re: cb stays on channel 1

Postby jimgumtow » Tue Jul 03, 2012 9:45 pm

thanx. i'll try that

User avatar
budavari
Posts: 19
Joined: Sun May 06, 2012 10:54 am
Location: La Puente, CA
Motorcycle: 1993 GL1500A Aspencade

Re: cb stays on channel 1

Postby budavari » Tue Jul 03, 2012 11:40 pm

The best way to clean the switch is to take apart the switch assembly and spray the inside working part of the switch with electrical contact cleaner followed by silicone spray lubricant. Don't use WD-40, it will end up being gummed up after time as it attracts dirt.

greatwhite
Posts: 2
Joined: Sat Jul 07, 2012 7:57 am
Location: fall river,ma
Motorcycle: "1995 GL1500SE"

Re: cb stays on channel 1

Postby greatwhite » Sat Jul 07, 2012 11:12 am

I just had the same problem where the radio stations wouldn't go up or down
and I had to remove the radio connectors and clean them.
They were all corroded.




Return to “GL1500 Information & Questions”




Who is online

Users browsing this forum: GlimWas and 1 guest