Page 1 of 2

ECU fuel circuit failure

Posted: Fri Oct 26, 2012 12:48 pm
by Emmette
I am new to this forum but have searched for a similar problem with no success. My problem: I have a 1998 GL1500A Aspencade purchased about a year and a half ago. Within the last 6 months, I had a problem with the fuel pump and after checking thoroughly, (according to the manual) found that the ECU was faulty. Found a used one that I purchased and installed. Worked great! Now, within the last week, I am having problems with starting when cold. After trying to start with no success while cold, I will let it set for an hour or so and try again. Starts!! Today I thought I would do the same with no success. Checked and found, according to the manual, that the ECU fuel pump circuit is again faulty. My question; has anyone else run into a similar situation, and if so, what was the solution?> Thanks

Re: ECU fuel circuit failure

Posted: Fri Oct 26, 2012 1:23 pm
by virgilmobile
I have read on this forum of a few ECM modules failing to provide power to the pump.
Just from others analysis and repairs,I'm leaning toward a bad fuel pump as the cause.

The reasoning.....The original pump works,but has excessive current draw...this overloads the circuit in the ECM that runs the pump...
.........note that the pump is not fuse protected....

The constant overload damages the circuit in the ECM and renders the pump without power.
Replacing the ECM restores the pump operation....However it doesn't fix the cause....The pump..

A worn bearing,impellers or just wear can put a excessive strain on the pump and it will still work.
It will draw as much power as it needs to run till something burns up.The ECM.

I'll bet if you bypass the power to the pump directly to the battery and test it for flow and pressure,you may find it's low.
Unfortunately I do not know the normal current draw.Perhaps someone here does.

Don't let the ECM run the pump for the tests,as I said before,if something is bad in the pump,there is no current protection for the ECM.

This is just my opinion and subject to debate.
I usually try to find WHY a part failed so I might prevent that failure again.
Virgil

Re: ECU fuel circuit failure

Posted: Fri Oct 26, 2012 1:32 pm
by Emmette
What you say makes a lot of sense. And.... the reason I posted was to try to find out how to prevent another ECM failure. Thanks for waking me up :)
Will see what I can find and go from there. Meanwhile, if anyone has a good, used ECM for sale, please contact me.

Re: ECU fuel circuit failure

Posted: Fri Oct 26, 2012 3:32 pm
by virgilmobile
In a ideal circuit there would never be a concern of damaging the ECM pump circuit.Unfortunately the designers of the circuit failed to implement any circuit protection from a abnormal current draw.Nowadays control modules often include current and voltage management circuits.
Apparently this dosent happen often enough to warrant any concern on the manufactures part.
I suppose one could take a pre-emtive measure by isolating the pump from the ECM with a relay and use a appropriate fuse to protect the pump.This way the ECM would only have to handle a 200 miliamp load rather than the pump.
Just a thought.
Your models pump is driven from the ECM direct,my 88 has a separate relay circuit for the pump.
Ive never heard of a 88-89ECM failing,just the later years.
New and improved isn't always better in the long run.

Re: ECU fuel circuit failure

Posted: Fri Oct 26, 2012 3:36 pm
by virgilmobile
One last thing.unplug your pump,attach a small lamp to the feed wire with a voltmeter and crank the engine.Measure the volts.There may be enough to operate a relay that could run the pump.The ECM might still have enough to get by but you should check into the pump anyways.

Re: ECU fuel circuit failure

Posted: Fri Oct 26, 2012 5:39 pm
by Emmette
I will definitely check the voltage from the ECM to the pump over the weekend. If it does have enough voltage to energize a relay it will certainly save a few bucks for
both the pump and ECM. Thanks much for the suggestions. Will post and let you know how it works out after I have had a chance to check it all out.

Re: ECU fuel circuit failure

Posted: Fri Oct 26, 2012 7:59 pm
by virgilmobile
If you go that route, use a fuse to protect the pump.I wouldn't think it would draw more than 2 or3 amps,so fuse it for no more than 5 amp.

Re: ECU fuel circuit failure

Posted: Fri Oct 26, 2012 8:22 pm
by Emmette
Okay. Sounds like a good idea. If it pulls more than 2 or 3 amps I'll just go ahead and order a new one. Got any suggestions other than the Honda
dealership? I have found over the years that at times a higher priced item at a dealership is cheaper in the long run. Just don't know about a pump, tho.

Re: ECU fuel circuit failure

Posted: Sat Oct 27, 2012 7:56 am
by virgilmobile
Don't make an assumption about the pump.I have no personal knowledge of exactly how much power they take under full load.This is just a estimate.
Also,a mate in the UK removed his pump and found debre inside.Seems the microscreen filter was bad.The pump uses the gas to cool and lubricate it.Every part of the pump runs in gas.
I wonder if a Honda prelude pump could work.More research is needed.
Keep us up to date please.This is of interest to many.

Re: ECU fuel circuit failure

Posted: Sat Oct 27, 2012 8:10 am
by Emmette
You have certainly given me much to consider. I will pull the pump first thing when I have an opportunity and check for debris. If nothing is found, I will be looking at pumps in general, including Prelude, Civic, Accord, etc. Most definitely will keep the forum updated on my progress.

Re: ECU fuel circuit failure

Posted: Sun Oct 28, 2012 10:03 pm
by WingAdmin
virgilmobile wrote:One last thing.unplug your pump,attach a small lamp to the feed wire with a voltmeter and crank the engine.Measure the volts.There may be enough to operate a relay that could run the pump.The ECM might still have enough to get by but you should check into the pump anyways.
I was thinking the same thing. A small relay is cheap insurance for an expensive ECM. I might add that to my winter maintenance list.

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 9:11 am
by virgilmobile
It would be nice to know how much current the pump draws under full load so one could properly fuse it.I'm only making an assumption on the 2-3 amps.
This could be a 'under the seat' mod for a bunch of wings.
Unplug the pump,add the relay right there and fuse to the battery.

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 9:44 am
by WingAdmin
virgilmobile wrote:It would be nice to know how much current the pump draws under full load so one could properly fuse it.I'm only making an assumption on the 2-3 amps.
This could be a 'under the seat' mod for a bunch of wings.
Unplug the pump,add the relay right there and fuse to the battery.
I've got a digital ammeter that will read up to 30 amps, I'll plug it in next time I have it apart and take a reading.

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 1:16 pm
by Emmette
A quick update. ECM fuel circuit was totally dead so no go on using it to power a relay. Pulled the pump to check for debris and found very little. Have found a used ECM and a new Accord fuel pump. When they both meet here at my shop I will install both of them along with a relay for the pump (fused also) and see what happens. Found a brief blurb on how to modify the Accord pump but somehow 'lost' it so will try to find it again before the pump arrives. Also will keep the forum advised on my progress. Thanks much to virgilmobile and WingAdmin for all the helpful hints.

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 1:43 pm
by Emmette
Wanted to correct my last post. I did not order an Accord pump but an Airtex E8371 which (according to the post I was reading) is a better pump with output, etc.,
closer to the original pump on the Wing. Will most likely be a few days before the pump and ECU arrives so will do as in the military... 'hurry up and wait'!!

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 2:38 pm
by virgilmobile
Somebody(including me) would be interested in inspecting the innards of your failed ECM module.
I'm most intrigued as to what actually failed and if it's repairable.
I'm not trying to drum up any business,lord knows I have enough of that kind of stuff now,but neverless,I am interested.
You know....inquiring minds and all :geek:

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 2:46 pm
by Emmette
Not a problem. Give me your address and I will be happy to send it to you. Actually have two, so will send one now. If you are able to repair it I will
send the other, if agreeable to you, you can repair it and return to me. Sound fair? Contact me via e-mail: wuneagle43@yahoo.com with your address if you
would like.

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 3:03 pm
by WingAdmin
virgilmobile wrote:Somebody(including me) would be interested in inspecting the innards of your failed ECM module.
I'm most intrigued as to what actually failed and if it's repairable.
I'm not trying to drum up any business,lord knows I have enough of that kind of stuff now,but neverless,I am interested.
You know....inquiring minds and all :geek:
That's a very good point - if the pump draws any kind of current (and it's a good bet it could be drawing at least a couple amps), the likelihood of the controlling bit of silicon in the ECM being integrated into an IC is probably low - there could very well be an easily-replaced discrete MOSFET or something that just needs the smoke reinstalled into it.

Re: ECU fuel circuit failure

Posted: Mon Oct 29, 2012 8:15 pm
by virgilmobile
I'm looking foreword to this.
Admin.....I'm gonna suggest one more thing too.
Add a 1 amp diode across the relay coil.
I've been seeing quite a few relay induced EMF spikes damaging transistor switching circuits.
We have been adding them to all relays as common practice as of last month.
I know you are aware of what it can do to a LED.

We do this only on relays that are transistor controlled,not switch operated.

Re: ECU fuel circuit failure

Posted: Tue Oct 30, 2012 10:43 am
by thrasherg
virgilmobile wrote:Add a 1 amp diode across the relay coil.
I've been seeing quite a few relay induced EMF spikes damaging transistor switching circuits.
We have been adding them to all relays as common practice as of last month.
This has been standard practice in the electronics industry for many years when a relay is driven by a semiconductor!! Good to point it out as many of us forget to do it.. :oops:

Gary

Re: ECU fuel circuit failure

Posted: Tue Oct 30, 2012 11:14 am
by WingAdmin
thrasherg wrote:This has been standard practice in the electronics industry for many years when a relay is driven by a semiconductor!! Good to point it out as many of us forget to do it.. :oops:

Gary
Yup, I've got a big bag of 1N400x diodes expressly for this purpose. And yes, I still forget all the time, too. :)

Re: ECU fuel circuit failure

Posted: Tue Oct 30, 2012 3:03 pm
by virgilmobile
For clarity,here a few pictures I found on Google.
The "input" would be the connection to the ECM output that would normally go to the pump.
Use a fuse from the Battery circuit to feed the relay contact and attach the fuel pump to the relay 'NO' connection.
A standard auto type relay (Bosch type) are usually number labled .
I would connect in this manner..
#85....band or 'plus' side of diode and connect to ECM.
#86....negative side of diode and connect to ground
#87....connect with fuse to battery positive
#30...connect to pump.
However you connect the diode is OK.
Now before anybody yells that I connected the hot wire to the wrong terminal (#87)..there's a reason for that.


If it's connected to #30..connection #87a will have volts on it when the relay is shut off.
I'm not switching 2 lugs only one.I don't want a hot lug exposed under the seat

Re: ECU fuel circuit failure

Posted: Tue Oct 30, 2012 3:11 pm
by WingAdmin
virgilmobile wrote:Now before anybody yells that I connected the hot wire to the wrong terminal (#87)..there's a reason for that.
If it's connected to #30..connection #87a will have volts on it when the relay is shut off.
I'm not switching 2 lugs only one.I don't want a hot lug exposed under the seat
I do the exact same thing when I'm not using the NC (87a) connection on a relay, for the same reason.

Re: ECU fuel circuit failure

Posted: Tue Oct 30, 2012 3:20 pm
by Emmette
Okay! Got the relay all wired (except for the diode... gotta get one), ready for install as soon as the pump and ECU arrives. Will keep you posted on the progress.
* "virgilmobile" the old ECU is on the way to you. Should be there by Thursday since I am in NW Fla. and it is shipping by UPS.

Re: ECU fuel circuit failure

Posted: Tue Oct 30, 2012 3:57 pm
by virgilmobile
Emmette wrote:Okay! Got the relay all wired (except for the diode... gotta get one), ready for install as soon as the pump and ECU arrives. Will keep you posted on the progress.
* "virgilmobile" the old ECU is on the way to you. Should be there by Thursday since I am in NW Fla. and it is shipping by UPS.
Radio shack should have what you need...Model: 1N4003 | Catalog #: 276-1102

Great on the ECU.That will give me something to do on my slow 1/2 day :)