'94 Aspy display & radio cuts out, dash lites up


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
84wingrider
Posts: 26
Joined: Wed Jul 15, 2009 12:35 pm
Location: Milan, IN
Motorcycle: 1994 GL1500 Aspencade

'94 Aspy display & radio cuts out, dash lites up

Postby 84wingrider » Sun May 05, 2013 12:34 pm



I have a '94 Aspencade. Went on a charity ride and stereo and LCD display cut out for 5 seconds. Dash lights then illuminated like i had just turned key on to start it, then stereo and display worked again. This happened several times throughout the day while riding. I read other articles where the stereo cuts out and that's all. I think my problem may be different since i'm losing display and dash lights are coming on...that's why i'm posting this. Any help would be appreciated.



User avatar
wingpilot08
Posts: 429
Joined: Wed Jan 18, 2012 4:43 pm
Location: Coatesville, PA
Motorcycle: 2008 GL1800-HPNA - 24,000+ miles
1988 Bunkhouse camping trailer
Darkside #1720

Re: '94 Aspy display & radio cuts out, dash lites up

Postby wingpilot08 » Sun May 05, 2013 1:24 pm

84wingrider wrote:I have a '94 Aspencade. Went on a charity ride and stereo and LCD display cut out for 5 seconds. Dash lights then illuminated like i had just turned key on to start it, then stereo and display worked again. This happened several times throughout the day while riding. I read other articles where the stereo cuts out and that's all. I think my problem may be different since i'm losing display and dash lights are coming on...that's why i'm posting this. Any help would be appreciated.



You #3 relay may be working itself loose...causing the intermittent on/off to you display and stereo...pull out the relay..clean it up, and plug it back in!
08' GL1800-HPNA - Red 24,000+ miles
1988 Bunkhouse Trailer/Camper
Darkside #1720

84wingrider
Posts: 26
Joined: Wed Jul 15, 2009 12:35 pm
Location: Milan, IN
Motorcycle: 1994 GL1500 Aspencade

Re: '94 Aspy display & radio cuts out, dash lites up

Postby 84wingrider » Sun May 05, 2013 5:20 pm

Thanks for the heads up wingpilot. Will def check relay #3 when the weather improves here. Raining and 50 degrees here...not optimal riding weather! :(


Return to “GL1500 Information & Questions”




Who is online

Users browsing this forum: No registered users and 3 guests