Radio Just Quit Working


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
igonzalezjr
Posts: 21
Joined: Sun Feb 07, 2010 4:18 pm
Location: las cruces new mexico
Motorcycle: 1983 Goldwing Interstate

Radio Just Quit Working

Postby igonzalezjr » Mon Jul 01, 2013 6:48 am



Hello all, my radio on my gl1500 just quit working, i checked the fuse box and did not find any blown fuses. The front speakers began to sound like they were blown and then everything went silent. I would appreciate any help regarding what to check next. Thank you and safe riding.



Ruaidh
Posts: 2
Joined: Mon Jun 21, 2010 4:07 pm
Location: Layton,UT
Motorcycle: 1990 GL1500

Re: Radio Just Quit Working

Postby Ruaidh » Mon Jul 01, 2013 9:52 am

Must be going around. Mine is beginning to play sound in mono while on station, but if you go up or down the dial one notch it is full stereo signal.

igonzalezjr
Posts: 21
Joined: Sun Feb 07, 2010 4:18 pm
Location: las cruces new mexico
Motorcycle: 1983 Goldwing Interstate

Re: Radio Just Quit Working

Postby igonzalezjr » Mon Jul 01, 2013 10:53 pm

I tried that and no cigar, it's just dead silence. i really don't know where to start looking other than take it to the shop and i'm trying to avoid that money mess. thanks anyway, take care and ride safe

User avatar
Sempai
Posts: 295
Joined: Wed Mar 10, 2010 12:30 am
Location: Wichita, KS
Motorcycle: '94 GL1500SE
Contact:

Re: Radio Just Quit Working

Postby Sempai » Tue Jul 02, 2013 8:12 am

This may or may not help you, but it might be a good idea to RECHECK your fuses:

I recently found two issues with my stereo, one a while back, the second, just a few weeks ago.
One problem was with the wiring harness connector(s) at the back of the radio itself. The problem I had here was the main power terminal was loose, I simply tightened the female terminals by bending them with a jeweler's screwdriver, I did ALL of the female terminals and the radio came on louder than it had ever been since I owned it.
After some time, I next had a problem with the display failing to come on, with this problem the stereo, cruise control, and on-board air pump all failed to work. After much troubleshooting, I discovered that it was a FUSE problem....lol...NOT that the fuse was bad, that was the very first thing I checked! What I'd discovered was that the female terminals into which this particular fuse plugged in...where loose. On occasion, there was enough contact to make it all work, but hit a slight bump in the road and it would fail. Again, minor tweaking with a jeweler's screwdriver and it all works just fine to this day.

Read more: viewtopic.php?f=6&t=17451#ixzz2XtRv7d4T
Keep the rubber side down.

User avatar
spiritofrodney
Posts: 11
Joined: Tue Apr 23, 2013 11:21 pm
Location: Friendswood, Texas
Motorcycle: 1996 GL1500 Goldwing

Re: Radio Just Quit Working

Postby spiritofrodney » Tue Jul 23, 2013 4:27 am

Thanks! I will give this a try and see if is solves my headache as easily as it did for you. Ive been pulling my hair out trying to figure this problem out.


SGT NORMAN MILLER, RETIRED
Da Bear on Da Beast
1996 GL1500


Return to “GL1500 Information & Questions”




Who is online

Users browsing this forum: Google Adsense [Bot] and 4 guests