Turn signal and radio problem gl1500 HELP PLEASE!

Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
Posts: 1
Joined: Thu Sep 19, 2013 1:52 am
Location: Fort Worth, Texas
Motorcycle: 1995 gl1500 Aspencade

Turn signal and radio problem gl1500 HELP PLEASE!

Postby dafreaknexdoe » Thu Sep 19, 2013 1:59 am

Hello forum, I'm new here and looking for help

I have a 95 1500 aspencade. I'm having some unusual problems.
My turn signals flash fast and the radio goes out when I
put the bike in gear. Out of gear, the turn signal indicator on the dash shine brighter when I hit the hand break, but the radio stays on and the flasher are the correct speed.
But as soon as I put it in gear the radio shuts off, and indicator shines bright. I checked the bulbs all are fine. I took out the relay fuse for the flashers thinking I needed to replace it. The Dealer told me to replace the relay the cost was $60. WOW, and they had to order it.
So after I calmed down from hearing that price for a fuse!!
I took the relay out and and noticed the socket had some corrosion in it. So I cleaned it and sprayed it with electrical cleaner and switched
the relay to another spot and tried it again. It stared off doing the same then stared working right. I put the bike back together, took it for a short ride
all was fine. After sitting for a week I took the bike out at first it was fine but then it starting acting up again.
Any help or suggestions would be appreciated but please note that I'm not mechanically inclined. So please explain it to me like I'm a 3 year old.

User avatar
Posts: 276
Joined: Sat Apr 10, 2010 9:25 pm
Location: Manchester, PA
Motorcycle: Current: 2008 GL1800
Previous: 96 GL1500 SE
85 GL1200 I
85 GL1200 I
75 GL1000

Re: Turn signal and radio problem gl1500 HELP PLEASE!

Postby artgrantz » Thu Sep 19, 2013 5:02 am

It sounds like you are on the right track by cleaning the connectors. Clean them all as best as you can then coat with dielectric grease (white bulb grease) before reassembling. This will help stop the corrosion. Any auto parts store will have it.
Hope this helps.

User avatar
Posts: 245
Joined: Wed Apr 25, 2012 12:28 pm
Location: London, England, United Kingdom
Motorcycle: 1988 GL1500 Panther Trike

Re: Turn signal and radio problem gl1500 HELP PLEASE!

Postby liquineer » Thu Sep 19, 2013 8:06 am

In my experience with car indicators flashing to fast, it usually indicates a poor earth (ground) somewhere- it may be it is within the relay or it could be elswhere.
Are we having fun yet?

User avatar
Site Admin
Posts: 16926
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Turn signal and radio problem gl1500 HELP PLEASE!

Postby WingAdmin » Thu Sep 19, 2013 12:14 pm

You've definitely got a bad ground. It appears your radio is using your neutral switch as a ground! When you shift out of neutral, the radio loses its ground, and shuts off. The radio has its own ground, but apparently that's gone bad, so it's finding ground wherever it can.

Return to “GL1500 Information & Questions”

Who is online

Users browsing this forum: Proximic [Bot] and 1 guest