Erratic dash display, radio, and cruise control


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
Post Reply
User avatar
MeneGene1971
Posts: 16
Joined: Sun Dec 14, 2014 7:15 am
Location: Lake, MI
Motorcycle: 1996 GL1500 SE

Erratic dash display, radio, and cruise control

Post by MeneGene1971 » Sun Jul 26, 2015 8:21 pm



I'm terrible at searching past subjects so I apologize if this has already been addressed. My 1996 GL1500 SE has an intermittent problem. About half the time after starting the engine the LCD display is blank. The radio does not work when this happens and I noticed today while riding that the cruise will not engage either. The "cruise on" light would come on after pushing in the button but I could not set a speed. I stopped and shut the bike off with the key, turned the key back on 3 times before the LCD came on. Started the engine and had no further problems. If I notice that the display is blank- that is the fix, turn the key off and back on once or twice. The display will usually come on. Then everything works. Before this started happening my clock would keep time. Now every time this occurs, the clock goes haywire. I read on another forum that relay #3 could be to blame. Any advice?


My Goldwing is not Purple- it's Royal Pearl Magenta! ;)

User avatar
WingAdmin
Site Admin
Posts: 18225
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Erratic dash display, radio, and cruise control

Post by WingAdmin » Mon Aug 10, 2015 4:17 pm

MeneGene1971 wrote:I'm terrible at searching past subjects so I apologize if this has already been addressed. My 1996 GL1500 SE has an intermittent problem. About half the time after starting the engine the LCD display is blank. The radio does not work when this happens and I noticed today while riding that the cruise will not engage either. The "cruise on" light would come on after pushing in the button but I could not set a speed. I stopped and shut the bike off with the key, turned the key back on 3 times before the LCD came on. Started the engine and had no further problems. If I notice that the display is blank- that is the fix, turn the key off and back on once or twice. The display will usually come on. Then everything works. Before this started happening my clock would keep time. Now every time this occurs, the clock goes haywire. I read on another forum that relay #3 could be to blame. Any advice?
Is the ENTIRE LCD blank, or just parts of it? i.e. is the clock on and nothing else? Or is it completely blank?

When the LCD is blank, does your radio work? At normal volume?

When the clock goes haywire, does this mean it just resets to 12:00?

User avatar
MeneGene1971
Posts: 16
Joined: Sun Dec 14, 2014 7:15 am
Location: Lake, MI
Motorcycle: 1996 GL1500 SE

Re: Erratic dash display, radio, and cruise control

Post by MeneGene1971 » Thu Aug 13, 2015 7:43 am

Happened twice yesterday so I was able to verify. The whole LCD is blank. I shut the key switch off, turn it back on, restart engine and no more problems until I turn the bike off again. Then it may or may not display again on the next start.
My Goldwing is not Purple- it's Royal Pearl Magenta! ;)

User avatar
WingAdmin
Site Admin
Posts: 18225
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Erratic dash display, radio, and cruise control

Post by WingAdmin » Mon Aug 17, 2015 3:28 pm

Does the radio work when the LCD is blank -i.e. can you change stations etc?

nofishbob
Posts: 1
Joined: Mon Oct 28, 2013 4:07 pm
Location: Copper Canyon, Texas
Motorcycle: 1984 GL1200 Aspencade(sold)
2004 RC51 (sold)
2007 zx14 (sold)
1997 GL1500 SE

Re: Erratic dash display, radio, and cruise control

Post by nofishbob » Tue Aug 18, 2015 8:49 pm

I have recently been experiencing the same issue as the OP.
On my bike, it seems that the problem is actually related to the ignition key switch itself.
Yesterday, after just starting out for a ride, I noticed that the LCD was blank.
Turning the bike off then on again had worked in the past, so I pulled over and turned the bike off, then restarted it. This time it did not make the LCD come back on. Even after a few more cycles, no luck.
While the key was on, and the bike running, I pushed the key farther into the switch and wiggled it a little.
The LCD came on ! And stayed on.

It seems that the key switch has a marginal contact that is not energizing the solenoid(s) controlling these devices. Once the LCD came on, no amount of key wiggling would make it flicker or turn off. It stayed on then for my entire ride with multiple restarts.

Hope this helps.

Bob

User avatar
MeneGene1971
Posts: 16
Joined: Sun Dec 14, 2014 7:15 am
Location: Lake, MI
Motorcycle: 1996 GL1500 SE

Re: Erratic dash display, radio, and cruise control

Post by MeneGene1971 » Wed Aug 19, 2015 7:41 am

The radio will not work at all when the LCD is blank. I agree with the previous comment about the ignition switch. I have come to the same conclusion with trial and error. If I turn the ignition switch on quick, I notice that the LCD stays blank more often. If I turn the switch slowly and deliberately 1 click at a time, it never stays blank. Next time it happens, I will try wiggling the key and see if that fixes it.
My Goldwing is not Purple- it's Royal Pearl Magenta! ;)

prok2goldwing
Posts: 14
Joined: Thu Aug 20, 2015 4:37 pm
Location: Ashland Nebraska
Motorcycle: 1994 Honda Goldwing Aspencade 1500

Re: Erratic dash display, radio, and cruise control

Post by prok2goldwing » Fri Aug 21, 2015 9:11 am

So did you replace the ignition switch? and if you did, did it solve the problem??

User avatar
MeneGene1971
Posts: 16
Joined: Sun Dec 14, 2014 7:15 am
Location: Lake, MI
Motorcycle: 1996 GL1500 SE

Re: Erratic dash display, radio, and cruise control

Post by MeneGene1971 » Mon Aug 24, 2015 9:34 am

I haven't done anything about it yet. Just dealing with it. I'll most likely let it go terminal before I take the time to fix it.
My Goldwing is not Purple- it's Royal Pearl Magenta! ;)

User avatar
carpet
Posts: 15
Joined: Mon Oct 24, 2011 1:33 am
Location: Toowoomba, Australia
Motorcycle: 1996 GL1500 Aspencade

Re: Erratic dash display, radio, and cruise control

Post by carpet » Fri Feb 03, 2017 1:54 am

Hmm. Thank the lord i found this piece of info. My 96 aspencade just started to do this exact thing only mine also had no self-cancelling of the left or right indicator. I had the fork oil replaced and then after my shakedown ride i noticed 2 days later a strong gas smell coming from the old girl. Low and behold the petcock was leaking so i replace that one myself(again with help from the info found here).
Taking it for a ride yesterday i noticed that the indicators didn't cancel and nothing in the lcd and cruise wouldn't set. Got home lifted off radio/cassette thinking i had a loose connection with the wiring harness or something but everything was tight. Started her up again and everything was working again. Okay i fixed it i thought. Went out this morning to fuel up for a weekend trip with the boys and it did it again. Lifted roller door and started it again and it works. what the. Got back online to this site and found the same thing happened to others. Will monitor over the weekend. By the way maybe heat has something to do with it as it has been damn hot here, 36c-41c the last week. Gee i hope it's nothing to do with the colour, mine is royal magenta as well.
Stay upright.

User avatar
carpet
Posts: 15
Joined: Mon Oct 24, 2011 1:33 am
Location: Toowoomba, Australia
Motorcycle: 1996 GL1500 Aspencade

Re: Erratic dash display, radio, and cruise control

Post by carpet » Sun Feb 05, 2017 6:50 pm

Back after a 1200klm round trip in 37c plus heat and the lcd, cruise and indicators only went off once on turning ignition on. Turned it off and slowly turned back on again and hey presto everything working again. Might just live with it and turn key on slowly in future cause i wouldn't even know where to begin except maybe the ignition switch.



Post Reply