cruise won't work,set light stays on


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
kenthewrench
Posts: 3
Joined: Mon Jul 12, 2010 12:52 pm
Location: Palm Bay,FL
Motorcycle: GL1500

cruise won't work,set light stays on

Postby kenthewrench » Tue Jul 13, 2010 2:09 pm



been going round and round with this one.Both bulbs go thru check when key is turned on then "on" light goes off and "set" light stays on. I have ohmed the switches and seem to be working correctly. Anyone come accross this yet ???

P.S.----I work on a ton of these GL1500's in my shop so if anyone needs anything please feel free to give me a call. My shop is K&R Cycle Works,LLC. located in Melbourne,FL. We are having our delayed Grand Opening this saturday( July 17th) with free food,music, door prizes,50/50,and specials on tires and parts.All are invited,thanks. Ken(321-917-2369)



pigpen
Posts: 4
Joined: Wed Aug 26, 2009 8:38 pm
Location: clarkston, mi
Motorcycle: 1988 gl1500

Re: cruise won't work,set light stays on

Postby pigpen » Tue Jul 20, 2010 7:57 pm

check the clutch and brake handles. they wear at the pivot and cause the cruise not to set.

kenthewrench
Posts: 3
Joined: Mon Jul 12, 2010 12:52 pm
Location: Palm Bay,FL
Motorcycle: GL1500

Re: cruise won't work,set light stays on

Postby kenthewrench » Wed Jul 21, 2010 8:47 am

Thanks but its more than a matter of some switches.The "set" light stays on after the initial bulb check when the ignition if turned on. It does have some switch issues,but I've rulled them out by manually jumping them. I even disconnected the cruise module in the rear and the light "still" stays on.I'm thinkin the solidstate module in the dash is bad. Thanks for your input though!!! Ken

User avatar
wbetheajr
Posts: 65
Joined: Mon Aug 10, 2009 12:01 pm
Location: Archdale, NC
Motorcycle: 1982 gl1100i interstate

Re: cruise won't work,set light stays on

Postby wbetheajr » Fri Jul 23, 2010 2:41 pm

mine don't have a light problem but On my 92 aspencade when I turn on the cruise control the indicator lite comes on but when I try to lock in the speed nothing happens. Got to be something simple I hope.

bigl54
Posts: 17
Joined: Fri Jun 18, 2010 9:24 am
Location: LaQuinta,Ca.
Motorcycle: "1991 GL1500 Aspencade

Re: cruise won't work,set light stays on

Postby bigl54 » Mon Jul 26, 2010 8:24 am

i have a 91 aspy with cruise switch problems, have a new switch assembly on order, mechanic said 2 hours to put in.looking at just under 400$.ouch! 19 year old bike with open switches, it happens. bigl54

moose00ca
Posts: 1
Joined: Tue Mar 03, 2009 2:07 pm
Location: Canada

Re: cruise won't work,set light stays on

Postby moose00ca » Sun Aug 01, 2010 8:06 pm

I had the same problem (cruise not working), replaced the small brass peice in the clutch lever cost about $5 nice easy fix.

ttysseling
Posts: 3
Joined: Tue Aug 03, 2010 4:57 pm
Location: Eagar, AZ
Motorcycle: 1998 Goldwing Aspencade

Re: cruise won't work,set light stays on

Postby ttysseling » Tue Aug 03, 2010 5:27 pm

I have a 1998 Aspencade. I just bought it a month ago. I noticed right away that when I pushed the button to turn off the cruise it didn't turn off. I played with it a little and found that the button was sticking. The solution was low tech, I just sprayed some WD40 around the edges of the button and worked it in and out a couple of times.

User avatar
heidebill
Posts: 144
Joined: Thu Apr 01, 2010 12:54 am
Location: Onoway Alberta, Canada
Motorcycle: 1997 GL1500SE

Re: cruise won't work,set light stays on

Postby heidebill » Sat Aug 14, 2010 12:05 am

Same as moose00ca Just replaced that little brass bushing mine was $6 Clutch lever feels smoother and the cruise works now, The switch was not making contact when the bushing was worn out. simple Bill

alextele
Posts: 8
Joined: Fri Mar 12, 2010 3:13 pm
Location: dallas, texas
Motorcycle: 1989 GL1500 Goldwing

Re: cruise won't work,set light stays on

Postby alextele » Mon Aug 16, 2010 4:26 pm

ok guys.. it sounds like I could have this same problem with the clutch lever. Im not sure but, my question is, can anyone send me some pics of this defective part and how do I replace it???

all my dash lights work when I start the bike. the cruise ON works fine. It just wont SET. I already replaced the CRUISE switch on my right handlebar.

I would like to give this clutch lever trick a try... Any pics would be helpful.. or detailed instructions or both.. Im easy..

Thanks
my email is: dm5642@sbcglobal.net

thanks again

User avatar
heidebill
Posts: 144
Joined: Thu Apr 01, 2010 12:54 am
Location: Onoway Alberta, Canada
Motorcycle: 1997 GL1500SE

Re: cruise won't work,set light stays on

Postby heidebill » Tue Aug 17, 2010 9:00 am

It's Simple, I don't have any pictures, You just remove the pivot bolt for the clutch lever, and the lever comes out in your hand, Inset into the lever is the little brass bushing, about 5/16 dia, it also just pops out, Lube the new one and re-assemble. Easy. Bill

alextele
Posts: 8
Joined: Fri Mar 12, 2010 3:13 pm
Location: dallas, texas
Motorcycle: 1989 GL1500 Goldwing

Re: cruise won't work,set light stays on

Postby alextele » Tue Aug 17, 2010 1:02 pm

Bill,
Thank you so much for the info. I am so glad I have a goldwing. It seems like all of the goldwing riders hang together and help each other out. Thanks a bunch to the ones who provided this board for us to stay in touch also.

If anyone might be interested, I just replaced my entire suspension system with the progressive rear air shocks and front for springs along with the ALL BALLS bearings for the steering head. Its like riding a completely different bike. IT handles like a dream. I believe that the problem I have heard on here about the tires wearing unevenly is a result of the OEM shocks on this bike. I was shocked to find only 1 airshock on the rear and 1 spring shock.

With 2 rear air shocks on the back it made all the difference.

Ride safe, Ride free and fight for bikers rights..

bigl54
Posts: 17
Joined: Fri Jun 18, 2010 9:24 am
Location: LaQuinta,Ca.
Motorcycle: "1991 GL1500 Aspencade

Re: cruise won't work,set light stays on

Postby bigl54 » Wed Aug 18, 2010 11:04 am

Had the mechanic install the 150$ switch assembly,he tested it worked, i drove it, and it did not work,took it back, and he put an intermitent switch on 14$. 9 times out of 10 it works. 10 out of 10 it works if I apply a little pressure outwardly on the brake handle while setting cruise speed. Tells me it was a probably a 6$ part. Oh well I have new switches now. I purchased a 91 aspy 5 months ago with 45000 miles on it , it now has over 50000. the more I drive it the more I like it .




Return to “GL1500 Information & Questions”




Who is online

Users browsing this forum: FM-USA, Google Adsense [Bot], Ricvannatta and 6 guests