dead radio


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
ditchdr
Posts: 2
Joined: Sun Jul 25, 2010 1:38 am
Location: Arabi, Ga
Motorcycle: 1988 1500

dead radio

Postby ditchdr » Sun Jul 25, 2010 2:11 am



Looking for help troubleshooting my 1500 audio. Radio is getting power, CB works, but I can't get a peep out of the radio. I "THINK" that I've checked the wiring and fuses?



User avatar
robb
Posts: 1040
Joined: Mon Jul 19, 2010 7:46 pm
Location: Lexington, North Carolina
Motorcycle: 1989 Honda GL1500 Aspencade

Re: dead radio

Postby robb » Mon Jul 26, 2010 10:31 pm

Have you checked the dash switches. The 89 I just bought would not work after sitting for 2 years. Switches were lightly corroded, but after a cleaning all is good.

User avatar
nightwizard40
Posts: 9
Joined: Sun Jul 19, 2009 6:50 pm
Location: Alabama, USA
Motorcycle: 1989 GL1500

Re: dead radio

Postby nightwizard40 » Thu Jul 29, 2010 11:43 am

Also check your mute switch, and the switch on the radio to change from speakers to headset....

Can you not hear anything through the headsets either?

If all else fails, send it to Sierra Electronics and let Wayne and them have a go at it. They are great and very good priced.

ditchdr
Posts: 2
Joined: Sun Jul 25, 2010 1:38 am
Location: Arabi, Ga
Motorcycle: 1988 1500

Re: dead radio

Postby ditchdr » Fri Jul 30, 2010 4:50 am

Thanks guys,
I really think that this thing has bit the bullet. Theres power to the radio, back-up power to the radio, and a good ground. I can't get a peep out of it. My clock shows up on the LCD, but, nothing from the radio. CB comes on, but, it has no sound.




Return to “GL1500 Information & Questions”




Who is online

Users browsing this forum: Bluewaterhooker0, Jrthrash1959 and 4 guests