Cruise control button


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
farmer66
Posts: 2
Joined: Mon Jan 03, 2011 7:28 pm
Location: Lufkin, TX
Motorcycle: 1998 GL1500 Aspencade

Cruise control button

Postby farmer66 » Thu Jul 14, 2011 9:23 pm



I am having trouble with the cruise control on my 1998 Aspencade. It has set up for years, and has 7,000 miles. I cleaned the carbs and have it running very well. Maybe one in ten times the two cruise control symbols will briefly light up when the key is turned on. They stay on just for a split second. The cruise control on-off switch will not stay depressed when it is pushed. If I put tape over it to keep it depressed, then both symbols light up when the key is turned on, I can set the speed and the cruise control works fine.

Does this sound like simply a bad on-off switch, or something else? Is replacing the switch a big deal or a small deal?

Thanks in advance,

Ken



User avatar
keithg64
Posts: 343
Joined: Thu May 21, 2009 9:47 pm
Location: Geneseo, IL
Motorcycle: 2000 GL1500 Pearl Coranado Blue

Re: Cruise control button

Postby keithg64 » Sun Jul 17, 2011 5:47 pm

I would take the right side cruise throttle houseing apart and just clean the electrical contacts with contact cleaner and see how that works. There are 3 bolts from the underside with a phillips screw driver.
It's not what you buy, it's what you build.

farmer66
Posts: 2
Joined: Mon Jan 03, 2011 7:28 pm
Location: Lufkin, TX
Motorcycle: 1998 GL1500 Aspencade

Re: Cruise control button

Postby farmer66 » Tue Jul 19, 2011 10:51 pm

I took it apart as you described and sprayed penetrating oil in the switch. Pushed it in maybe a hundred times, then it started working! Thanks for the tip.

Ken


Return to “GL1500 Information & Questions”




Who is online

Users browsing this forum: keithg64 and 5 guests