RADIO NOT WORKING


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
RODNEY
Posts: 2
Joined: Mon Aug 08, 2011 9:32 pm
Location: PETAL MS
Motorcycle: 1989 HONDA GOLDWING 1500 ASPENCADE

RADIO NOT WORKING

Postby RODNEY » Thu Aug 11, 2011 8:12 am



The radio will not come the cb comes on i get nothing from speakers and also the lcd screen is not working



User avatar
robb
Posts: 1040
Joined: Mon Jul 19, 2010 7:46 pm
Location: Lexington, North Carolina
Motorcycle: 1989 Honda GL1500 Aspencade

Re: RADIO NOT WORKING

Postby robb » Thu Aug 11, 2011 8:22 pm

Will the bike run. If not check main fuse.

User avatar
Sempai
Posts: 295
Joined: Wed Mar 10, 2010 12:30 am
Location: Wichita, KS
Motorcycle: '94 GL1500SE
Contact:

Re: RADIO NOT WORKING

Postby Sempai » Thu Sep 15, 2011 4:34 pm

I had this problem. Check the fuse....lol....as I first did. I pulled my hair out tryin to figure this one out. The fuse was good, but the radio didn't work. Problem was the terminals in which the fuse plugs in. I tightened them with a jewler's screwdriver, just by bending them closed a bit, and the radio/lcd, cruise control, and on board air compressor all came back to working condition.
Another problem I'd found before this fuse connectivity issue was that the main power wire connection to the back of the radio itself was faulty...again due to the female receptacle being loose.
Keep the rubber side down.


Return to “GL1500 Information & Questions”




Who is online

Users browsing this forum: krhh, MSNbot Media [Bot] and 5 guests