Page 1 of 1

Budding Electrical Problem

Posted: Tue Apr 01, 2014 1:29 am
by Cleetorn
In the last several days, I have noticed that while I am driving my '06 down the highway, the turn signal lights on the panel come on dimly simultaneously for a while. When that happens, the cruise control disengages and will not re-engage. When I try to use the turn signal to change lanes, they work insipidly but both panel lights flash like they were emergency flashers. When I push on the brakes, both panel lights illuminate brightly. The Fuel Injection light comes on for a moment and then goes out. The engine doesn't seem to miss a beat while this is going on. Of course, I can't see what the lights are actually doing while I am riding. Only problem is that when I get where I am going, the malfunction resolves itself and everything works normal again. It's tough to trace down a problem that won't manifest itself except when I am on the road. Anybody ever had anything like this happen to them? All thoughts and considerations would be greatly appreciated.

Re: Budding Electrical Problem

Posted: Tue Apr 01, 2014 8:47 am
by thrasherg
Unfortunately this sounds like a ground fault. They are usually very difficult to find. Try doing a search for ground or earthing faults and see what is suggested.

Best of luck

Gary

Re: Budding Electrical Problem

Posted: Tue Apr 01, 2014 12:00 pm
by canuck623
Definitely a ground issue. The fact it doesn't happen at a stop is odd for sure. If you can get a friend to ride behind you and in front of you so you can see if the exterior bulbs are doing anything funny when you are moving. A shorted to ground bulb could cause what you are describing and it may only show it's head when the vibrations of movement are present.