blank nav screen


Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
Post Reply
montanasparky
Posts: 2
Joined: Tue Jul 15, 2014 5:25 pm
Location: Mt Dora, FL
Motorcycle: 2008 Honda goldwing

blank nav screen

Post by montanasparky » Tue Jul 15, 2014 6:43 pm



After reinstalling the trunk and side bags on my 2008 Goldwing the nav screen powers up but does not display anything. Could I have blown a fuse? If so where is it, there is no listing for the nav system on the fuse panel? Thanks for any help in advance.



User avatar
tfdeputydawg
Posts: 966
Joined: Sun Nov 22, 2009 6:59 am
Location: Indianapolis, In.
Motorcycle: 06 Wing III/2010 Hannigan

Re: blank nav screen

Post by tfdeputydawg » Tue Jul 15, 2014 7:24 pm

Check the harness connectors. Very easy to not plug all the way together or to bend even break one or more of the pins!

Smok1bear
Posts: 9
Joined: Fri Apr 25, 2014 7:00 am
Location: Broadview hts, Ohio
Motorcycle: GL1800 Audio/Comfort/Navi/ABS GL1800HPNA :2008

Re: blank nav screen

Post by Smok1bear » Wed Jul 16, 2014 10:20 am

Check the fuse marked for the battery. Same thing happened to my 2008. Screen would light up briefly, or should I say flash white, and then go black. Hope this helps you out.

montanasparky
Posts: 2
Joined: Tue Jul 15, 2014 5:25 pm
Location: Mt Dora, FL
Motorcycle: 2008 Honda goldwing

Re: blank nav screen

Post by montanasparky » Sat Jul 19, 2014 6:03 pm

Thanks guys tried both, but still nothing.

Hondaretro
Posts: 9
Joined: Wed Jul 16, 2014 3:49 pm
Location: Salem
Motorcycle: 2003 gl1800

Re: blank nav screen

Post by Hondaretro » Mon Jul 21, 2014 4:14 pm

Try unplugging and pluging back in with power on will reboot.



Post Reply