code 26


Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
rsc4526
Posts: 2
Joined: Fri Nov 07, 2014 1:32 pm
Location: Welsh, Louisiana
Motorcycle: 2004 GL1800, non ABS

code 26

Postby rsc4526 » Fri Nov 07, 2014 2:00 pm



Need help, please. 04 GL 1800 non ABS. In July FI light came on, put side stand down, get code 26, left knock sensor. If I stop and shut off engine light will not come back on for at least 40 miles, sometime hundreds of miles. It's gotten worse, now it's every time I restart. I swapped left and right knock sensor, removed the terminal from the connector and tightened the terminal so it will contact the prong better on the sensor and ecu side, ohm tested the wire for short to ground or short to power, and cut the wire at the sensor and ecu and ran an outside wire. Swapped right and left sensors again. Light comes on immediately above 2500 RPM. And I remove the battery terminal between each test or swap so the code is cleared.
Another thing, I don't know if it's significant. If I jump the connector under the seat for the codes I get a 26, but also a 41- gear position switch. I will NOT get the 41 putting the side stand down. I have done all the test per the Honda service manual and all test good. Also, everything works proper; cruise, reverse, OD indicator, side stand down indicator, etc. Any help is appreciated.



User avatar
WingAdmin
Site Admin
Posts: 17045
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: code 26

Postby WingAdmin » Fri Nov 07, 2014 2:48 pm

rsc4526 wrote:Need help, please. 04 GL 1800 non ABS. In July FI light came on, put side stand down, get code 26, left knock sensor. If I stop and shut off engine light will not come back on for at least 40 miles, sometime hundreds of miles. It's gotten worse, now it's every time I restart. I swapped left and right knock sensor, removed the terminal from the connector and tightened the terminal so it will contact the prong better on the sensor and ecu side, ohm tested the wire for short to ground or short to power, and cut the wire at the sensor and ecu and ran an outside wire. Swapped right and left sensors again. Light comes on immediately above 2500 RPM. And I remove the battery terminal between each test or swap so the code is cleared.
Another thing, I don't know if it's significant. If I jump the connector under the seat for the codes I get a 26, but also a 41- gear position switch. I will NOT get the 41 putting the side stand down. I have done all the test per the Honda service manual and all test good. Also, everything works proper; cruise, reverse, OD indicator, side stand down indicator, etc. Any help is appreciated.


You've done absolutely everything correct, every step you've taken is exactly what I would have done to diagnose the problem.

Unfortunately, the problem you're experiencing is a common symptom of a bad ECU - and the fact that you've done everything but replace the ECU, I think I'm pretty safe in saying your next step is to source a replacement ECU.

reggiefavre
Posts: 22
Joined: Wed Apr 13, 2011 9:39 pm
Location: Petal, Ms
Motorcycle: 1981 GL Interstate

Re: code 26

Postby reggiefavre » Fri Nov 07, 2014 9:21 pm

Have you checked all ground connections. I am talking all of them. So much of that bike is plastic.

rsc4526
Posts: 2
Joined: Fri Nov 07, 2014 1:32 pm
Location: Welsh, Louisiana
Motorcycle: 2004 GL1800, non ABS

code 26

Postby rsc4526 » Tue Dec 23, 2014 5:21 pm

A few weeks ago I asked everyone's opinion on a code 26 on my 04 GL 1800 non ABS. It turned out to be the ECM as suspected. However it was a little hard to find. Most places said it was backordered, with an unknown arrival date. A dealer in

Texas had one in stock, but at full retail, $560. Partzilla finally got one for $377, but took about a month. That's alright, I was in no hurry, and the bike ran like it was. Everything is good now. Thank you all very much!! Merry Christmas!

User avatar
WingAdmin
Site Admin
Posts: 17045
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: code 26

Postby WingAdmin » Wed Dec 24, 2014 2:32 pm

Good news! Glad you got it worked out. You did the exact correct method of diagnosis, and as a result found the problem and got the bike fixed.




Return to “GL1800 Information & Questions”




Who is online

Users browsing this forum: Google [Bot] and 5 guests