Radio doesn't have any power!

Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
Posts: 2
Joined: Tue Apr 28, 2015 12:44 pm
Location: locust grove, ok
Motorcycle: 2001 gl1800 Goldwing

Radio doesn't have any power!

Postby sixmedic » Tue Apr 28, 2015 7:37 pm

Radio was working when put in storage now getting ready to ride and the radio doesn't work. Suggestions? Fuse is good.

Red Ron
Posts: 293
Joined: Thu May 20, 2010 1:13 pm
Location: Prestonsburg, KY; Edgewater FL
Motorcycle: '08, '13 GL1800
Rear-Yoko Avid Envigor 195x55x16
Front-Battleaxe BT-45

Re: Radio doesn't have any power!

Postby Red Ron » Tue Apr 28, 2015 8:57 pm

I think when a 1800 battery charge gets low enough it will divert all power to starting. Does the battery show a proper charge when load tested? Or maybe see if the radio will come on when a trickle charger is hooked to the battery.

User avatar
Posts: 647
Joined: Wed Sep 24, 2014 5:56 pm
Location: Oregon
Motorcycle: 2013 F6B

Re: Radio doesn't have any power!

Postby CMReynolds1 » Tue Apr 28, 2015 9:17 pm

The following are voltage readings on a battery with the bike off. It is pretty self explanatory.

Battery Life:
Measured in an ‘at rest state’.
Motor off and no charge applied to battery.

12.7 VDC 100%
12.5 VDC 90%
12.4 VDC 80%
12.3 VDC 70%
12.2 VDC 60%
12.0 VDC 50%
11.9 VDC 40%
11.8 VDC 30%
11.6 VDC 20%
11.3 VDC 10%
10.5 VDC 0%
Ride Safe,

TF 116, RivRon 512, Can Tho, S. Vietnam, 8/66-/9/68, GM(G)2

Posts: 3
Joined: Wed Feb 08, 2012 3:08 pm
Location: NRH, Texas
Motorcycle: 2005 gl 1800a

Re: Radio doesn't have any power!

Postby mudbug » Sat May 02, 2015 10:26 pm

check to see if by some chance you have pushed the MUTE BUTTON

Return to “GL1800 Information & Questions”

Who is online

Users browsing this forum: No registered users and 2 guests