Fuel quantity gauge stopped indicating


Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
ASSEY146
Posts: 3
Joined: Sun Feb 01, 2015 12:09 pm
Location: St. Louis, Missouri
Motorcycle: 1985 GL1200 Aspencade
2004 GL1800

Fuel quantity gauge stopped indicating

Postby ASSEY146 » Thu Mar 03, 2016 2:51 pm



My 2004 GL1800 Fuel quantity gauge stopped reading. It is almost permanently stuck at the empty level, apart from moving once or twice to half way before falling back to empty. The fuel tank sender unit and wiring to the instrument cluster all check out good. I suspect its a problem with the circuit board housed within the instrument cluster.
Does anyone know of any electronic shops that deal with instrument cluster repairs, or have had similar problem.



User avatar
WingAdmin
Site Admin
Posts: 17050
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Fuel quantity gauge stopped indicating

Postby WingAdmin » Thu Mar 03, 2016 3:44 pm

If you disconnect this connector on the fuel tank:

Fuel sender connector
Fuel sender connector


Then use a wire to connect the grey/black wire in that connector to ground, turn ignition on, does the fuel gauge move at all? (it should go to Full)

ASSEY146
Posts: 3
Joined: Sun Feb 01, 2015 12:09 pm
Location: St. Louis, Missouri
Motorcycle: 1985 GL1200 Aspencade
2004 GL1800

Re: Fuel quantity gauge stopped indicating

Postby ASSEY146 » Thu Mar 03, 2016 4:08 pm

Thanks wings Admin. No the gauge did not move when i earthed the Grey/Black wire from the Tank sender unit

User avatar
WingAdmin
Site Admin
Posts: 17050
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Fuel quantity gauge stopped indicating

Postby WingAdmin » Fri Mar 04, 2016 3:19 pm

My next step would to be ground out the same wire right at the instrument cluster, to rule out a broken wire in between there and the sender. If that still doesn't work, then you're looking at the gauge itself.

There aren't any published circuits for the gauge (and I suspect what is its internal voltage regulator) - Honda's service manual just says to "replace" if it tests bad. Not to say you might find something obviously wrong - broken wire, broken circuit board trace, etc.

ASSEY146
Posts: 3
Joined: Sun Feb 01, 2015 12:09 pm
Location: St. Louis, Missouri
Motorcycle: 1985 GL1200 Aspencade
2004 GL1800

Re: Fuel quantity gauge stopped indicating

Postby ASSEY146 » Wed Mar 09, 2016 3:18 pm

Thanks wingadmin for your sound advice. I have now fixed the problem. It was a circuit board fault as first suspected. I source a replacement instrument cluster off ebay as i had zero help from the guys that repair car instrument clusters around the country.
It was somewhat smashed up on the case, but the instruments and circuit board all where ok.
I plugged it into my wing and everything worked including the fuel gauge. I decided to swap out the fuel gauges using my original gauge. That worked. I then plugged in my original instrument cluster with the fuel gauges swapped over - did not indicate.
So have rebuilt the instrument cluster using the good parts and have it plugged in and playing as it should. Cheers again




Return to “GL1800 Information & Questions”




Who is online

Users browsing this forum: No registered users and 5 guests