2007 Gl1800 switch problems


Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
SideCarJerry
Posts: 14
Joined: Sun Mar 27, 2016 3:40 pm
Location: Medford New Jersey
Motorcycle: 2007 GL1800

2007 Gl1800 switch problems

Postby SideCarJerry » Sun Mar 27, 2016 3:52 pm



we just picked up a 2008 GL1800 that was our late Uncles bike. .several switches do not work .the Cruise control switch doesnt turn off the cruise .that i am hoping can be cleaned and lube to get it working .i cant set the clock .i push the set up button and it does nothing.also the info button does nothing.everything else seems fine .any ideas.Thanks



SideCarJerry
Posts: 14
Joined: Sun Mar 27, 2016 3:40 pm
Location: Medford New Jersey
Motorcycle: 2007 GL1800

Re: 2007 Gl1800 switch problems

Postby SideCarJerry » Sun Mar 27, 2016 4:22 pm

sorry its a 2007 not a 2008.

User avatar
salty1
Posts: 91
Joined: Wed Aug 20, 2014 4:32 pm
Location: Spokane, Wa/Tucson, Az
Motorcycle: 98 GL1500 C, 00 GL1500CF, 06 GL1800 3A

Re: 2007 Gl1800 switch problems

Postby salty1 » Sun Mar 27, 2016 6:09 pm

Try contact cleaner, forget the lube. If they still don't work get ready to shell out some cash. Honda only sells the assembly ( item 2 below).

http://www.partzilla.com/parts/search/H ... parts.html

SideCarJerry
Posts: 14
Joined: Sun Mar 27, 2016 3:40 pm
Location: Medford New Jersey
Motorcycle: 2007 GL1800

Re: 2007 Gl1800 switch problems

Postby SideCarJerry » Sun Mar 27, 2016 8:07 pm

The setup,info,trip,dim switch doesn't work .what would cause that ? i wish i could find a picture or a part number.is this part of the display or seperate ?

User avatar
salty1
Posts: 91
Joined: Wed Aug 20, 2014 4:32 pm
Location: Spokane, Wa/Tucson, Az
Motorcycle: 98 GL1500 C, 00 GL1500CF, 06 GL1800 3A

Re: 2007 Gl1800 switch problems

Postby salty1 » Sun Mar 27, 2016 8:32 pm

Have you had the top shelter off lately? That gang of switching maybe unplugged. :?: However, if that assembly is required to be purchased it is sold as one unit (item 1) in schematic. Does the display show anything or is it blank? If it shows some things it's probably okay.

User avatar
salty1
Posts: 91
Joined: Wed Aug 20, 2014 4:32 pm
Location: Spokane, Wa/Tucson, Az
Motorcycle: 98 GL1500 C, 00 GL1500CF, 06 GL1800 3A

Re: 2007 Gl1800 switch problems

Postby salty1 » Sun Mar 27, 2016 8:34 pm


SideCarJerry
Posts: 14
Joined: Sun Mar 27, 2016 3:40 pm
Location: Medford New Jersey
Motorcycle: 2007 GL1800

Re: 2007 Gl1800 switch problems

Postby SideCarJerry » Sun Mar 27, 2016 8:58 pm

the display works .what does it plug into .i see a connector hanging there .i may get a mirror and see if i can see anything. dont know the history of whats really been done to it .the person who had it passed away a year ago .

SideCarJerry
Posts: 14
Joined: Sun Mar 27, 2016 3:40 pm
Location: Medford New Jersey
Motorcycle: 2007 GL1800

Re: 2007 Gl1800 switch problems

Postby SideCarJerry » Mon Mar 28, 2016 1:07 pm

i was looking at a video on changing the air filters and it showed where the plug goes.they must have not plugged it in when it was serviced .it works good now.i will clean the switch tomorrow and then i will be in good shape.thanks

User avatar
salty1
Posts: 91
Joined: Wed Aug 20, 2014 4:32 pm
Location: Spokane, Wa/Tucson, Az
Motorcycle: 98 GL1500 C, 00 GL1500CF, 06 GL1800 3A

Re: 2007 Gl1800 switch problems

Postby salty1 » Mon Mar 28, 2016 7:02 pm

Watch this YouTube and you will see the plug for the panel of switches and the connection point. It's only one plug.




SideCarJerry
Posts: 14
Joined: Sun Mar 27, 2016 3:40 pm
Location: Medford New Jersey
Motorcycle: 2007 GL1800

Re: 2007 Gl1800 switch problems

Postby SideCarJerry » Mon Mar 28, 2016 7:31 pm

Thanks Salty 1 . lot of great info on this site.only other stuff is some messed up wiring for some after market fender lights so by the weekend everything should be in great shape

User avatar
salty1
Posts: 91
Joined: Wed Aug 20, 2014 4:32 pm
Location: Spokane, Wa/Tucson, Az
Motorcycle: 98 GL1500 C, 00 GL1500CF, 06 GL1800 3A

Re: 2007 Gl1800 switch problems

Postby salty1 » Mon Mar 28, 2016 7:42 pm

Good luck! I have a few of those lighting issues myself left over from the PO. Its the trim lights on the trunk and saddlebags that are messed up. Share some pics when you get it all beautiful.




Return to “GL1800 Information & Questions”




Who is online

Users browsing this forum: No registered users and 4 guests