2003 1800 elec problems


Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
musketballs
Posts: 2
Joined: Sat Mar 15, 2014 6:03 pm
Location: Denton, Maryland
Motorcycle: 2003 dl1800

2003 1800 elec problems

Postby musketballs » Mon Aug 15, 2016 7:07 am



Runs fine but: gas and temp gauge pegged, tach and speedo read 0, trip and odometer won't register miles as you ride, headlights brake and turn signals work but will not self cancel, radio works but does not show channel etc. on display but opening ceremony works, no tail lights, cruise comes on but won't engage, clock works when running but resets at restart of engine. I think that's most of it. I have ripped off tons of plastic and checked connections, fuses, etc. and found no problems. Reset ecm. No help. Also fan does not work and shows no f1 code. I hate to replace a 250+ dollar part like the ecm and find out that's not the problem. If anyone has experienced this and resolved it, I'd sure love to know.
Thanks
Tony



harvey01
Posts: 629
Joined: Thu May 31, 2012 7:14 pm
Location: Henrico, Virginia
Motorcycle: 2004 GL1800

Re: 2003 1800 elec problems

Postby harvey01 » Mon Aug 15, 2016 11:48 am

Have you had the battery load tested? Did you check all ground locations?
harvey
Ride Safe and Ride Often

musketballs
Posts: 2
Joined: Sat Mar 15, 2014 6:03 pm
Location: Denton, Maryland
Motorcycle: 2003 dl1800

Re: 2003 1800 elec problems

Postby musketballs » Mon Aug 15, 2016 6:03 pm

Yes to the load test and all the grounds I could locate.


Return to “GL1800 Information & Questions”




Who is online

Users browsing this forum: Yahoo Slurp [Bot] and 1 guest