CB problems PTT and Static

Information and questions on GL1800 Goldwings (2001-2017)
  • Sponsored Links
Post Reply
Posts: 10
Joined: Thu Aug 29, 2013 1:12 pm
Location: Newbury Park, CA
Motorcycle: 1990 GL1500SE
1993 GL1500 A

CB problems PTT and Static

Post by liflyboy » Tue Jan 30, 2018 2:58 pm

2 problems with the Evolution Model EV01A, CB on my 2016 GL1800.

1) The CB push-to-talk switch is not working well. At the beginning of the day, I have to work the switch on and off for about 5 - 10 minutes before it makes contact. Once it's working, it works OK for the rest of the day, with possibly a little wiggle necessary. I've tried spraying with contact cleaner, and that doesn't help. I'm to the point where I have to take the switch apart, but I heard that it can be tedious, and parts will come flying out at me, when I take it apart.

First issue is, how does the switch assembly come off the handlebar. Is it easy to remove so I can put it on the bench?

Then, of course, I could use some instruction of taking the switch apart to get to the contacts. Is there some instruction video, or text, that I could use for reference?

Also, is there somewhere to buy just the PTT switch without buying the whole assembly?

2) It worked fine, until a few months ago, even with the PTT switch issue, but then one day, the others in my group told me to stop transmitting, all they are hearing is LOUD STATIC! I've checked all the wiring, the plug under the seat, the antenna, and everything seems to be properly installed. Any ideas what might cause the static output, if it's not the PTT switch?


Post Reply