Dead radio 2007 GL1800 Navi


Information and questions on GL1800 Goldwings (2001-2017)
  • Sponsored Links
Post Reply
GeGe
Posts: 5
Joined: Sat Mar 17, 2018 12:13 pm
Location: 7790 Malm
Motorcycle: 2002 GL1800A

Dead radio 2007 GL1800 Navi

Post by GeGe » Sat Mar 17, 2018 12:35 pm



Hi
have a friend with a 2007 GL1800 Navi. After he made a jump start radio do not work at all. No information from radio in LCD display, but navigation works well.
We tried to switch radio with another one, but no success. There is light in radio buttons when turning ignition key to On or ACC. I checked "Power Amp" relay under seat, but no click there when turning ignition to On or ACC. This relay i guess power up external amplifier when turning ignition On.
Is there a fuse before "Power Amp" relay that might be blown, and if thats the reason. Where is the fuse ?
What other fuses might be blown ?

i tried to find Service manual for this model, but without success. Anyone can help me ?

Thanks a lot :D :D :D



User avatar
jinx
Posts: 291
Joined: Sat Jan 30, 2010 11:42 am
Location: Mechanics,pa
Motorcycle: 2006 gl1800
2177 gl1800

Re: Dead radio 2007 GL1800 Navi

Post by jinx » Sat Mar 17, 2018 2:36 pm

Check fuse 31 in the fuse panel/box.

GeGe
Posts: 5
Joined: Sat Mar 17, 2018 12:13 pm
Location: 7790 Malm
Motorcycle: 2002 GL1800A

Re: Dead radio 2007 GL1800 Navi

Post by GeGe » Sat Mar 17, 2018 2:39 pm

Okay. Check it tomorrow.
I let you all know result 😀

GeGe
Posts: 5
Joined: Sat Mar 17, 2018 12:13 pm
Location: 7790 Malm
Motorcycle: 2002 GL1800A

Re: Dead radio 2007 GL1800 Navi

Post by GeGe » Sun Mar 18, 2018 7:19 am

Radio still dead. Fuse 31 and all other fuses Ok

GeGe
Posts: 5
Joined: Sat Mar 17, 2018 12:13 pm
Location: 7790 Malm
Motorcycle: 2002 GL1800A

Re: Dead radio 2007 GL1800 Navi

Post by GeGe » Sun Mar 18, 2018 8:09 am

Radio dead
CB dead
Nothing happens when i hit any button on the radio unit.

User avatar
newday777
Posts: 858
Joined: Tue Jan 11, 2011 5:21 pm
Location: Milford NH and Oceanside, CA (N San Diego)
Motorcycle: 2008 Cabernet Red. Level 4

1983 GL1100A Wineberry to sell 36,000 miles

1999A Restored and sold at 19,000 miles

1999SE Totaled by cager at 105,000 miles

Re: Dead radio 2007 GL1800 Navi

Post by newday777 » Sun Apr 01, 2018 2:47 am

"We tried to switch radio with another one, but no success."

1-What part/parts of the radio did you try to swap with another???
2- Where are you located?
GeGe wrote:
Sat Mar 17, 2018 12:35 pm
Hi
have a friend with a 2007 GL1800 Navi. After he made a jump start radio do not work at all. No information from radio in LCD display, but navigation works well.
We tried to switch radio with another one, but no success. There is light in radio buttons when turning ignition key to On or ACC. I checked "Power Amp" relay under seat, but no click there when turning ignition to On or ACC. This relay i guess power up external amplifier when turning ignition On.
Is there a fuse before "Power Amp" relay that might be blown, and if thats the reason. Where is the fuse ?
What other fuses might be blown ?

i tried to find Service manual for this model, but without success. Anyone can help me ?

Thanks a lot :D :D :D

GeGe
Posts: 5
Joined: Sat Mar 17, 2018 12:13 pm
Location: 7790 Malm
Motorcycle: 2002 GL1800A

Re: Dead radio 2007 GL1800 Navi

Post by GeGe » Sun Apr 01, 2018 6:22 am

We tried to swap the radio unit. Not tried anything with amplifier yet. All relays and fuses are okay, but radio still dead.
Perhaps there might be a problem with meter-combination panel ?

I'm located in Norway
This is a US model bike with Navi and without airbag

PS! I found the OEM service manual and have it downloaded



Post Reply