2007 gl1800 electrical

Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
Posts: 1
Joined: Fri Feb 11, 2011 5:36 pm
Motorcycle: 2007 gl1800 delux

2007 gl1800 electrical

Postby andycc » Wed Mar 02, 2011 12:52 am

Hi firstly my rear suspension failed after just 6000 miles now there is no charge going from the alternator to the battery can anybody give me any ideas thanks

Posts: 10
Joined: Sun Nov 15, 2009 11:27 pm
Location: Anson,TX
Motorcycle: 2006 GL1800

Re: 2007 gl1800 electrical

Postby ltcwm » Mon Mar 07, 2011 6:00 pm

Check all cable connections. + - Then onto the electrical relays under the seat. GOOD Luck. ;)

Posts: 5
Joined: Mon Aug 30, 2010 8:07 pm
Location: Maysville,WV
Motorcycle: 2010 Gl1800

Re: 2007 gl1800 electrical

Postby wvprez2 » Tue Mar 08, 2011 2:20 pm

Unusual GL1800 Battery Charging Problem. Jim Sadler from Australia found this. No charge was going into his battery, even though the alternator was giving full output and the regulator checked out okay. Turns out his cruise control fuse had blown and when this fuse blows the battery won't charge.

User avatar
Posts: 53
Joined: Sat Sep 05, 2009 10:23 am
Location: Inverness, Scotland
Motorcycle: GL1800

Re: 2007 gl1800 electrical

Postby gogs11uk » Tue Mar 08, 2011 5:53 pm

My thoughts exactly. Heard about this one before and was going to suggest it but you beat me to it.

User avatar
Posts: 12
Joined: Sun Jan 30, 2011 6:20 pm
Location: Red Deer AB
Motorcycle: 2007 Goldwing Nav Lehmann Trike
1993 Goldwing Aspencade

Re: 2007 gl1800 electrical

Postby kcburgess » Tue Mar 08, 2011 8:39 pm

Check the wiring harness running down the right side of the forks.... my 07 kept blowing the fuse and I found the wires chafted and would short out and blow the fuse when you turned right.

Old age is when you are told to slow down by a doctor instead of a policeman!

Return to “GL1800 Information & Questions”

Who is online

Users browsing this forum: No registered users and 3 guests