Injectors etc.


Information and questions on GL1800 Goldwings (2001-Present)
  • Sponsored Links
pattayapaul
Posts: 11
Joined: Sun Dec 18, 2011 1:21 am
Location: Thailand
Motorcycle: 2004 Goldwing 1800
2002 BMW R1200c

Injectors etc.

Postby pattayapaul » Sun Jan 29, 2012 10:24 pm



I took out the injectors and cleaned and checked them because the engine wasn't idling properly and stalling. I found that the bottom O ring was detached and laying at the bottom of the chamber. I fixed, cleaned and tested, all was ok until I tried to start the engine.
It would not start, no petrol pump functioning or spark in the plugs. I finally sent it to the shop who have now told me that the ECM needs to be replaced at a cost of 50,000 Thai Baht or £1,000.
Q. Can't these be repaired or reprogramed? And where did I go wrong? Was I supposed to disconnected the ECM before I took the Injector leads off?
Someone please answer my questions. :'(



User avatar
jinx
Posts: 252
Joined: Sat Jan 30, 2010 11:42 am
Location: Mechanics,pa
Motorcycle: 2006 gl1800

Re: Injectors etc.

Postby jinx » Mon Jan 30, 2012 8:02 am

first in order to try and help I have to assume the shop is wrong.
What happens when you turn the key on and press the start button ?
Do the lights go out, does the engine turn ?
Have you checked the Kill switch? I'm not trying to be smart but you would
be surprised.

pattayapaul
Posts: 11
Joined: Sun Dec 18, 2011 1:21 am
Location: Thailand
Motorcycle: 2004 Goldwing 1800
2002 BMW R1200c

Re: Injectors etc.

Postby pattayapaul » Mon Jan 30, 2012 6:15 pm

Thanks for your help.
I have only just found out about the FI error codes, so I will be trying that today.
The bike was working fine except for the stalling and gas consumption was high.
It turns over but there is no spark or petrol supply and I know nothing about a Kill Switch. Although I will investigate on the internet today to see where its located.

User avatar
jinx
Posts: 252
Joined: Sat Jan 30, 2010 11:42 am
Location: Mechanics,pa
Motorcycle: 2006 gl1800

Re: Injectors etc.

Postby jinx » Mon Jan 30, 2012 6:33 pm

If it truns over when you press the starter than it is not the kill switch which is on the right hand controls.
if you get an F1 code let me know I will look it up for you.
Have you checked all fuses ? Have you checked the side stand switch ?
Do you hear the fuel pump charge up when you turn on the ign ?


Sorry for the shotgun approach.

pattayapaul
Posts: 11
Joined: Sun Dec 18, 2011 1:21 am
Location: Thailand
Motorcycle: 2004 Goldwing 1800
2002 BMW R1200c

Re: Injectors etc.

Postby pattayapaul » Mon Jan 30, 2012 6:51 pm

Fuel pump not working, 7 volt supply is there. I just cleaned the injectors and found that the bottom O-ring was detached from the number 1 injector and laying at the bottom of the cylinder. I also cleaned the air filter.
When trying to start it cranks over but does not fire.

User avatar
jinx
Posts: 252
Joined: Sat Jan 30, 2010 11:42 am
Location: Mechanics,pa
Motorcycle: 2006 gl1800

Re: Injectors etc.

Postby jinx » Mon Jan 30, 2012 6:57 pm

Fuel pump should have battery voltage .

pattayapaul
Posts: 11
Joined: Sun Dec 18, 2011 1:21 am
Location: Thailand
Motorcycle: 2004 Goldwing 1800
2002 BMW R1200c

Re: Injectors etc.

Postby pattayapaul » Mon Jan 30, 2012 7:25 pm

Yes, but Pump not working

User avatar
Sally
Posts: 421
Joined: Wed Apr 20, 2011 10:25 am
Location: Dundee,NY
Motorcycle: 02 goldwing

Re: Injectors etc.

Postby Sally » Mon Jan 30, 2012 7:54 pm

First thing it's FI = fuel injection not f1 or fl, second are you working on a GL1800 there center port injected on top of intake.not in the cylinder. Sound like to me you did not get one of the many plugs back together right.You had to unplug what about 15 plugs to get the top shelter off, you unpluged the ecm and othe mods. to get to the air filter. You need to go back over it and make sure all plugs are matchedwhere they came out of and make sure they all connected right. Almost postive it's a plug. Good luck...SALLY :roll:

prolly just needs new spark plugs and an air filter.

pattayapaul
Posts: 11
Joined: Sun Dec 18, 2011 1:21 am
Location: Thailand
Motorcycle: 2004 Goldwing 1800
2002 BMW R1200c

Re: Injectors etc.

Postby pattayapaul » Mon Jan 30, 2012 11:03 pm

Hi Sally
According to the manual it is FI a Fault Indicator, which when used, gives you the error codes..
Thanks for your help.

User avatar
Sally
Posts: 421
Joined: Wed Apr 20, 2011 10:25 am
Location: Dundee,NY
Motorcycle: 02 goldwing

Re: Injectors etc.

Postby Sally » Tue Jan 31, 2012 8:07 pm

That is correct it monitors the whole fuel system even O2 sensors. Sally Have you had a time to re check all the plugs ?

pattayapaul
Posts: 11
Joined: Sun Dec 18, 2011 1:21 am
Location: Thailand
Motorcycle: 2004 Goldwing 1800
2002 BMW R1200c

Re: Injectors etc.

Postby pattayapaul » Wed Feb 01, 2012 5:29 am

Thanks Sally
I wi ll let you know tomorrow :-)

User avatar
Cal-D
Posts: 32
Joined: Sun Aug 30, 2009 9:32 am
Location: Nova Scotia
Motorcycle: 2007 Stream Silver GL1800A

Re: Injectors etc.

Postby Cal-D » Wed Feb 01, 2012 1:10 pm

If you had the air filter off, that is where I would start, go back and check every plug connection. My bet is there is a plug disconnected under the shelter.

pattayapaul
Posts: 11
Joined: Sun Dec 18, 2011 1:21 am
Location: Thailand
Motorcycle: 2004 Goldwing 1800
2002 BMW R1200c

Re: Injectors etc.

Postby pattayapaul » Wed Feb 01, 2012 10:33 pm

Thanks, I will check




Return to “GL1800 Information & Questions”




Who is online

Users browsing this forum: Aussie81Interstate and 2 guests