Search found 5 matches

by cbrown3146
Tue Aug 12, 2014 11:17 pm
Forum: GL1500 Information & Questions
Topic: Three Fuel Pumps
Replies: 4
Views: 228

Re: Three Fuel Pumps

Put a charger on the battery last night and it fired right up today. Could hear the pump working. Guess it needed a full charge. Thanks for all your input and support.
by cbrown3146
Tue Aug 12, 2014 9:28 am
Forum: GL1500 Information & Questions
Topic: Three Fuel Pumps
Replies: 4
Views: 228

Re: Three Fuel Pumps

I pulled the line off the pump and no flow.  It was running before i hooked up the line (tested for flow before I hooked it up).  The lines are not clogged as it was running on a gravity feed. I think something (wiring) is making it intermittent. Going to poor gas in the line and see if it needs a p...
by cbrown3146
Mon Aug 11, 2014 10:08 pm
Forum: GL1500 Information & Questions
Topic: Three Fuel Pumps
Replies: 4
Views: 228

Three Fuel Pumps

Wow frustrated!! I had no fuel flow from my OEM fuel pump. Put in a new NAPA pump and had the same results. Took it back to NAPA and got another one and checked it before hooking up the fuel line. Good flow. So I go to start it with same old results. Pulled fuel line cranked and got nothing. It does...
by cbrown3146
Sun Jul 03, 2011 9:44 am
Forum: GL1000 Information & Questions
Topic: Adding pictures to your message
Replies: 124
Views: 464699

Re: Adding pictures to your message

How do i add photo to my profile? thanks
by cbrown3146
Sun Jul 03, 2011 8:47 am
Forum: GL1500 Information & Questions
Topic: Radio Mute stuck on mute
Replies: 3
Views: 458

Re: Radio Mute stuck on mute

About the stuck mute button try elect. circut cleaner. Mine also got stuck and i sprayed a bunch and it worked so well i sprayed everything including knobs. Good luck