Page 1 of 1

'75 GL1000 My engine will only run with the starter button pushed in

Posted: Sat Jul 06, 2019 10:57 pm
by randyrogge
Hi,

A few months back, I was riding my GL1000 and my timing belt broke. Now after installing new valves and hopefully getting the valve timing correct. The bike will start and stay running only when the starter button is held in and laying on the throttle. Immediately after you release either one the engine will die. I'm not a mechanic by nature, so I would apprciate any help or pointed in the right direction. Thanks

Here is what I've done so far.

New timing belts
Replaced bent valves
Valve timing
Changed engine coils (OEM)
New plugs
I have spark

Re: '75 GL1000 My engine will only run with the starter button pushed in

Posted: Sat Jul 06, 2019 11:31 pm
by winguyjo
this would be a good time to check compression.

Re: '75 GL1000 My engine will only run with the starter button pushed in

Posted: Sun Jul 07, 2019 2:32 am
by Maz
randyrogge wrote: Sat Jul 06, 2019 10:57 pm Hi,

A few months back, I was riding my GL1000 and my timing belt broke. Now after installing new valves and hopefully getting the valve timing correct. The bike will start and stay running only when the starter button is held in and laying on the throttle. Immediately after you release either one the engine will die. I'm not a mechanic by nature, so I would apprciate any help or pointed in the right direction. Thanks

Here is what I've done so far.

New timing belts
Replaced bent valves
Valve timing
Changed engine coils (OEM)
New plugs
I have spark
You may have dislodged a connector.
Check the ballast resistor on the coils. When start button is pressed, the resistor is by-passed and full 12v is fed to the coils to give a stronger spark while the starter is spinning . When you release the button, voltage to the coils is diverted through the resistor. If resistor is faulty or disconnected, no spark = no run.
Maz

Re: '75 GL1000 My engine will only run with the starter button pushed in

Posted: Sun Jul 07, 2019 7:13 am
by DenverWinger
+1 on the compression check. I'd also revisit the valve lash adjustments.

Re: '75 GL1000 My engine will only run with the starter button pushed in

Posted: Sun Jul 07, 2019 7:42 am
by dingdong
Maz is correct. Ballast resistor is disconnected or bad.

Re: '75 GL1000 My engine will only run with the starter button pushed in

Posted: Tue Jul 09, 2019 5:22 pm
by Overdog
Yep...ballast resistor. Anyone who owned old Mopars probably changed a few.....