Accelerator pump


Information and questions on GL1100 Goldwings (1980-1983)
Post Reply
Cosmobiker
Posts: 63
Joined: Sat Nov 18, 2017 8:28 am
Location: Ålesund, Norway
Motorcycle: 1980 gl1100

Accelerator pump

Post by Cosmobiker »



I noticed when installing the floatbowl with the accel pump that the operating rod is pressed in when conecting with the lever. Is this like it should be or is the pump rod supposed to be able to return all the way after activating. I have a problem with flooding. I guess it is the float height that is off. But i want to be shure that the pump is correct installed.


User avatar
virgilmobile
Posts: 9101
Joined: Sun Sep 19, 2010 5:39 pm
Location: Denham Springs,La.
Motorcycle: 1988 GL1500 I
Previously owned
78 GL1000
81 GL1100
82 GL1100 I
83 GL1100 I
83 GL1100 standard
84 GL 1200 I

Re: Accelerator pump

Post by virgilmobile »

I'm recalling from years ago so beware...
When assembled,the pushrod of the accelerator pump is fully extended with a bit of space to the lever that operates it.
It's spring loaded so it should move with the throttle from the idle position to wide open and return when the throttle is closed.


Cosmobiker
Posts: 63
Joined: Sat Nov 18, 2017 8:28 am
Location: Ålesund, Norway
Motorcycle: 1980 gl1100

Re: Accelerator pump

Post by Cosmobiker »

Took the lever off. It was kinda wobbly from wear over the years. So i put a washer on the inside against the carb. It became more rigid. Since it moved out a bit, it gave the rod more space it seems Now there is no force pushing the floatbowl up when taking off the screws. So it is testing time.
Post Reply