STS smart turn module woes on GL1100


Information and questions on GL1100 Goldwings (1980-1983)
Post Reply
User avatar
Rc67
Posts: 80
Joined: Sun May 20, 2018 6:26 pm
Location: Jackson, ms
Motorcycle: 1980 GL1100I

STS smart turn module woes on GL1100

Post by Rc67 »



So I decided to get the smart turn module and proceeded to install it. I had to pull the headlight off to trace the wires down (lt Blue, Orange, Grey). I found that the wire loom came right out of the grommet on the back left side of the headlight shell, leading to the body frame under the faux tank. following the directions I looked for the ACC and ground, and found inside the headlight shell is a Brown wire that has nothing connected to it and the Green Wire (ground) I'm assuming based on a diagram ( which in all honesty, I'm trying to figure out). when I cut the wires and capped them with the fittings that came with the module, I went ahead and followed the diagram. I initially tested the brown wire to see if it was getting acc power when I turned the key and it showed 10.58V power when back to zero when I turned the key off so I assumed this would make a good connection.

Initially, when I tested the module the blinker blinked briefly to show that the module was connected properly and I could proceed to connect the switch. I went thru the instructions and tested the system.
It is supposed to blink either left or right depending on the movement of the switch you would then need to push it in the same direction to turn it off. well, it blinked in either direction and but would not cut off unless I forced it the other direction. this told me that something is wrong. I have two questions

1. is the Brown and Green good wire connections for the ACC and Ground or should I be using another color?
2. If there is a good place to find the directions or someone that has done this before, I would surely like to see that. I just can't find anything on google, youtube, etc.


User avatar
Rc67
Posts: 80
Joined: Sun May 20, 2018 6:26 pm
Location: Jackson, ms
Motorcycle: 1980 GL1100I

Re: STS smart turn module woes on GL1100 (Update)

Post by Rc67 »

So I found the wires necessary to power the module. I"m faced with a new dilemma, when everything is fully connected one of the turn signal lights, at the handlebar console, stays lit? I rechecked all of the wiring patterns and it all looks correct so I'm confused as to what is going on. Is there anyone on this forum that has successfully connected it to their GL1100?
Post Reply