Clock not working (Solved)

Information and questions on GL1200 Goldwings (1984-1987)
Post Reply
Posts: 8
Joined: Thu Nov 06, 2014 2:35 pm
Location: Brantford, Ontario, Canada
Motorcycle: 1984 Goldwing Aspencade GL1200

Clock not working (Solved)

Post by BanditJake »

The clock in my 84 Aspencade was not working and reading found that there are the two fuses under the left fairing compartment when you lift the tray out.
the 7,5 am fuse was good but there was no voltage one wire goes to clock the other goes to the plugs of wiring that go to the outside harness. The first bottom one is the red wire for that fuse and I noticed corrosion. I tugged on wire and came right out.

I then pulled on the harness on the plug on the outside and noticed corrosion on that plug. I gave a tug on the red live wire and it came out also.

I used vinegar and salt solution you can find on-line how to remove corrosion from wires, cleaned wires tried solder the one on outside got some on and to the wire on inside I had harder time to solder to it so I opted with putting connectors put a wire threaded it out the hole where the CB antenna wires come in and connected the two wire via the male and female connectors. Now fuse has voltage and clock works.

But now there is a drain on the battery, To bad that clock could work from when key is turned on.

Post Reply