water pump 84 1200 I


Information and questions on GL1200 Goldwings (1984-1987)
Post Reply
Smaltz79
Posts: 17
Joined: Sun Apr 17, 2016 7:09 pm
Location: Sugar Land TX
Motorcycle: 1984 Goldwing Interstate

water pump 84 1200 I

Post by Smaltz79 »



i have replaced my water pump twice non my 84 goldwing. It was very cold in Houston yesterday (20's to 30's) so i started it up and found that the water pump started leaking again. I used OEM at $130 a pop. What am i doing incorectly?



User avatar
oldishwinger
Posts: 414
Joined: Sun Jul 14, 2013 11:26 pm
Location: New Zealand
Motorcycle: 1986 GL1200 Aspencade

Re: water pump 84 1200 I

Post by oldishwinger »

where is it leaking from? It wont be the pump itself I dont think but if it coming from the cover that goes over the pump, and attaches to the lower radiator hose, then here is a rubber seal there that is probably the culprit, if its coming from the weep hole under the bike, then it will be the inside water pump seal.

did you renew the seals with the new pump?

User avatar
RoadRogue
Posts: 2069
Joined: Sun Jun 06, 2010 10:51 pm
Location: southern Okanogan BC, Canada
Motorcycle: 1997 1500SE

Re: water pump 84 1200 I

Post by RoadRogue »

Did you lube the o-ring seals when you installed the new pump? It is easy to roll the o-ring out of its groove if installed dry. 8-)
Ride safe, Todd
Over night campers welcome

Smaltz79
Posts: 17
Joined: Sun Apr 17, 2016 7:09 pm
Location: Sugar Land TX
Motorcycle: 1984 Goldwing Interstate

Re: water pump 84 1200 I

Post by Smaltz79 »

Thanks for the responses. Yes followed installation to the T. lube the new gaskets and installed. the first new one made a funny sound, so i bought the second and followed the installation instructions. I noticed after i installed the second one i would have a drip every now & then.
But yesterday it was a small puddle. owned the bike for 3 years and probably have driven a total of 6 months. getting pretty frustrated. I guess that is what you get when you buy a bike in the winter with a blown head gasket.

Smaltz79
Posts: 17
Joined: Sun Apr 17, 2016 7:09 pm
Location: Sugar Land TX
Motorcycle: 1984 Goldwing Interstate

Re: water pump 84 1200 I

Post by Smaltz79 »

found the problem, thanks for all the help

User avatar
RoadRogue
Posts: 2069
Joined: Sun Jun 06, 2010 10:51 pm
Location: southern Okanogan BC, Canada
Motorcycle: 1997 1500SE

Re: water pump 84 1200 I

Post by RoadRogue »

Please fill us all in on what the problem was, it may help the next person with the same issue. 8-)


Ride safe, Todd
Over night campers welcome

Post Reply