1987 to 1200 I fuel pump


Information and questions on GL1200 Goldwings (1984-1987)
Post Reply
User avatar
ronscycle1
Posts: 60
Joined: Sat Oct 31, 2009 2:58 pm
Location: Kinmundy IL.
Motorcycle: 1987 gl 1200 I

1987 to 1200 I fuel pump

Post by ronscycle1 »



If the ignition source coils go bad does the fuel pump stop working ?



User avatar
injunjoe535
Posts: 15
Joined: Tue Dec 08, 2015 3:23 pm
Location: Cartersville, Ga.
Motorcycle: 1985 GL1200 Aspencade, 2003 Harley Davidson Ultra Classic, 2006 Harley Davidson Road King

Re: 1987 to 1200 I fuel pump

Post by injunjoe535 »

I don't have a shop repair manual in front of me, but I would guess that the coils don't supply power to the pump. One way of checking would be to see if you have power to the fuel pump by checking at the connector with a test light or volt meter.
Joe

User avatar
WingAdmin
Site Admin
Posts: 21304
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (sold)
1998 XV250 Virago (sold)
2012 Suzuki Burgman 400 (wife's!)
2007 Aspen Sentry Trailer

Re: 1987 to 1200 I fuel pump

Post by WingAdmin »

The fuel pump is activated directly by the ECU. The same circuit is used to actuate the air valve. Check the fuel pump relay to ensure that it is not bad. Also, I know it's stupid, but it has to be said - the engine kill switch also kills the fuel pump relay. The engine stop switch is connected to both the ignition coil AND the fuel pump relay coil, so if it is actuated you will get no spark and the fuel pump will not run.

Fuel circuit
Fuel circuit

If you put the engine in gear and leave the clutch lever out (meaning the bike will not crank), switch the ignition on, then press the starter button, the fuel pump should operate, even though the engine is not cranking.

User avatar
ronscycle1
Posts: 60
Joined: Sat Oct 31, 2009 2:58 pm
Location: Kinmundy IL.
Motorcycle: 1987 gl 1200 I

Re: 1987 to 1200 I fuel pump

Post by ronscycle1 »

Hi thank you for your help : bike SAT for about two months waiting to put tires it ran fine when I parked it waiting for the tires,got the tires put them on ,new battery,new tags,went to start it no start, backfired really loud a couple times sprayed carb cleaner in air filter ,still no start ,so I checked plugs for fire the front was fireing but not the back,so I crossed wires on coils by jumping them now had fire on the rear plug .So from what I've read it's the IGN pickup coils under the timing belts.Do you think that's what it is too ?The reason I asked about the fuel pump was because when I drained the carbs cause I knew it would be awhile before I could fix it , the carbs on the left side had gas in them but the two on the right had none and I cranked it over about five minutes trying to get it started before that. could this be because of the IGN pickup coils not telling the ECU not to let the fuel pump work ?

User avatar
ronscycle1
Posts: 60
Joined: Sat Oct 31, 2009 2:58 pm
Location: Kinmundy IL.
Motorcycle: 1987 gl 1200 I

Re: 1987 to 1200 I fuel pump

Post by ronscycle1 »

:D
ronscycle1 wrote:Hi thank you for your help : bike SAT for about two months waiting to put tires it ran fine when I parked it waiting for the tires,got the tires put them on ,new battery,new tags,went to start it no start, backfired really loud a couple times sprayed carb cleaner in air filter ,still no start ,so I checked plugs for fire the front was fireing but not the back,so I crossed wires on coils by jumping them now had fire on the rear plug .So from what I've read it's the IGN pickup coils under the timing belts.Do you think that's what it is too ?The reason I asked about the fuel pump was because when I drained the carbs cause I knew it would be awhile before I could fix it , the carbs on the left side had gas in them but the two on the right had none and I cranked it over about five minutes trying to get it started before that. could this be because of the IGN pickup coils not telling the ECU not to let the fuel pump work ?



Post Reply