front brake pads rubbing on rotor after speedometer drive replacement


Information and questions on GL1200 Goldwings (1984-1987)
Post Reply
edixon.ed73
Posts: 3
Joined: Tue May 09, 2017 4:10 pm
Location: Baldwin Mi
Motorcycle: 84 GL 1200 Standard
89 GL 1500

front brake pads rubbing on rotor after speedometer drive replacement

Post by edixon.ed73 »



I have a GL 1200 Standard that I just replaced the speedo drive on, but now my left brake pads are rubbing on the rotor, tried to push pistons in to try to adjust, but pistons will not push in.
Any thoughts would be appreciated



rzaugg
Posts: 120
Joined: Tue Oct 01, 2013 10:04 pm
Location: Cedar Rapids, Ia
Motorcycle: 1984 GL1200 Aspencade
1989 GL1500 Aspencade

Re: front brake pads rubbing on rotor after speedometer drive replacement

Post by rzaugg »

If you are describing the caliper pistons not going back as "they are already all the way in. Then my first guess is that there was a spacer that stuck to the original speedo drive that didn't get put back in. If your brakes were fine before, I would guess they still are.
Does the front tire look like it is centered between the forks. It could still be a stuck caliper, but I would recheck the work done for the speedo drive.

edixon.ed73
Posts: 3
Joined: Tue May 09, 2017 4:10 pm
Location: Baldwin Mi
Motorcycle: 84 GL 1200 Standard
89 GL 1500

Re: front brake pads rubbing on rotor after speedometer drive replacement

Post by edixon.ed73 »

Thanks for the reply.
I found that I put the drive in front of the tab on the leg and I might not have got the axel seated all the way but when I set the drive behind the tab the pads are not rubbing the rotor now

Post Reply