Tail light comes on and bike runs rough


Information and questions on GL1200 Goldwings (1984-1987)
Post Reply
rdhrcwi1
Posts: 10
Joined: Mon Jul 02, 2012 8:58 pm
Location: Richland Center, WI
Motorcycle: 1984 GL1200A Aspencade

Tail light comes on and bike runs rough

Post by rdhrcwi1 »



Today as I was riding the tail light warning light came on and the bike started to run rough. When I hit a bump sometimes the light would go off and it would run better. When I got home the light was still on but all tail lights and other lights were working. When I shut the bike off it was completely dead. Nothing on the dash would light up. Any thought or ideas what is going on and how to fix it. Thank you.



User avatar
detdrbuzzard
Posts: 1359
Joined: Thu Oct 23, 2008 5:54 am
Location: 42.23/83.33/636
Motorcycle: '11 bmw 1200gsa,'93se
'75750.'79750/9k
'79 750f
'06 st1300a

Re: Tail light comes on and bike runs rough

Post by detdrbuzzard »

check and be sure your battery is good and check to see of the stator is charging
'99 ST1100, '93 se
'75 cb750k, '79 cb 750f, '79 cb750 superK
cb 450sc, sunL70
'06 ST1300a
.... william

rdhrcwi1
Posts: 10
Joined: Mon Jul 02, 2012 8:58 pm
Location: Richland Center, WI
Motorcycle: 1984 GL1200A Aspencade

Re: Tail light comes on and bike runs rough

Post by rdhrcwi1 »

detdcbuzzard, battery could be changed but even with the battery charger on the battery nothing lights up on the dash. If not battery or stator, could it be the key switch?

User avatar
detdrbuzzard
Posts: 1359
Joined: Thu Oct 23, 2008 5:54 am
Location: 42.23/83.33/636
Motorcycle: '11 bmw 1200gsa,'93se
'75750.'79750/9k
'79 750f
'06 st1300a

Re: Tail light comes on and bike runs rough

Post by detdrbuzzard »

forgot but did you check the main fuse
'99 ST1100, '93 se
'75 cb750k, '79 cb 750f, '79 cb750 superK
cb 450sc, sunL70
'06 ST1300a
.... william

rdhrcwi1
Posts: 10
Joined: Mon Jul 02, 2012 8:58 pm
Location: Richland Center, WI
Motorcycle: 1984 GL1200A Aspencade

Re: Tail light comes on and bike runs rough

Post by rdhrcwi1 »

I checked a 30 amp fuse near the gas tank. It was burnt out. Tried the key nothing. Went to unhook battery and presto, the positive cable was loose. "Here's your sign". I guess I needed to start at the simplest thing first. :P

Thanks for the replies detdrbuzzard.

Ralph
Richland Center, WI



Post Reply