Horn slow to activate


Information and questions on GL1200 Goldwings (1984-1987)
Post Reply
RS23V0G
Posts: 11
Joined: Tue Aug 04, 2009 7:29 pm
Location: Toulon,IL
Motorcycle: 1987 gl1200a Aspencade

Horn slow to activate

Post by RS23V0G »



Has anyone had a problem with the horn slow to activate? My 87 Aspy takes 1-2 seconds to blow after hitting the button & obviously that dangerous.



User avatar
Maz
Posts: 743
Joined: Tue May 19, 2015 4:43 am
Location: Kent, UK
Motorcycle: 1975 GL1000K1
1976 CB500T
1979 CB750L
1990 Yamaha FJ1200
1993 Suzuki GS500E

Re: Horn slow to activate

Post by Maz »

Assuming power is reaching the horn as soon as you press the button (check across horn connections with a multimeter or test bulb) it probably just needs a little tweak of the tuning screw on the back of the horn.
Maz
Ironically, Common Sense is the LEAST common of all senses!

RS23V0G
Posts: 11
Joined: Tue Aug 04, 2009 7:29 pm
Location: Toulon,IL
Motorcycle: 1987 gl1200a Aspencade

Re: Horn slow to activate

Post by RS23V0G »

I forgot to mention that one of the horns is OEM and one is an automotive aftermarket. But the problem started long before I added the aftermarket one. I'll check your suggestion first.

User avatar
Maz
Posts: 743
Joined: Tue May 19, 2015 4:43 am
Location: Kent, UK
Motorcycle: 1975 GL1000K1
1976 CB500T
1979 CB750L
1990 Yamaha FJ1200
1993 Suzuki GS500E

Re: Horn slow to activate

Post by Maz »

If both horns are affected, the tuning screw won't help.
Maz
Ironically, Common Sense is the LEAST common of all senses!

User avatar
winguyjo
Posts: 356
Joined: Sat Aug 11, 2018 9:26 pm
Location: b.c. Canada
Motorcycle: wing1 : 1982 gl1100 interstate; resurrection complete. SOLD
wing2 : 1980 gl1100 interstate; resurrection complete. SOLD.
wing3 : 81gl1100i frame/82gl1100a engine/81cb900 bits. resurrection complete. naked. SOLD.
wing4 : 1977 gl1000 black w/ blue pinstripes; resurrection complete. SOLD
wing5 : 1977 gl1000 black w/gold pinstripes; nearly roadworthy when purchased, NOW RIDING.
wing6 : 1975 gl1000 blue; SOLD

Re: Horn slow to activate

Post by winguyjo »

my guess would be a corroded pathway. i would remove and clean all connections and switch contacts.

User avatar
WingAdmin
Site Admin
Posts: 21283
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (sold)
1998 XV250 Virago (sold)
2012 Suzuki Burgman 400 (wife's!)
2007 Aspen Sentry Trailer

Re: Horn slow to activate

Post by WingAdmin »

If you have two horns, and one is an automotive horn, I'm willing to bet the circuit is overloaded, and potentially has burned out the contacts on your horn switch. The wiring and switch for the horns is just barely adequate for the OEM horn system, and the full current for the horns is pulled through that wiring and switch.

If you put a high-amperage (like 30 or 40 amp) automotive relay in place of the horns, then run a new (fused) 12 or 14 gauge wire directly from the battery, through the relay contacts and from there to the horns, you'll get much higher current to the horns, the horns will be much louder as a result, and you won't burn out the horn button switch from overcurrent.

RS23V0G
Posts: 11
Joined: Tue Aug 04, 2009 7:29 pm
Location: Toulon,IL
Motorcycle: 1987 gl1200a Aspencade

Re: Horn slow to activate

Post by RS23V0G »

WingAdmin,
Great suggestion, I had considered adding a relay so it looks like i have another project. BTW, What brand relay do you you prefer?

Thanks!
Garry

User avatar
WingAdmin
Site Admin
Posts: 21283
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (sold)
1998 XV250 Virago (sold)
2012 Suzuki Burgman 400 (wife's!)
2007 Aspen Sentry Trailer

Re: Horn slow to activate

Post by WingAdmin »

RS23V0G wrote:
Wed May 13, 2020 3:16 pm
WingAdmin,
Great suggestion, I had considered adding a relay so it looks like i have another project. BTW, What brand relay do you you prefer?

Thanks!
Garry
I buy them in bulk quantities from Digikey, and I normally stick to brands I know. I looked it up, and the last time I ordered some, I bought 25 of these: https://www.digikey.com/product-detail/ ... -ND/646989

RS23V0G
Posts: 11
Joined: Tue Aug 04, 2009 7:29 pm
Location: Toulon,IL
Motorcycle: 1987 gl1200a Aspencade

Re: Horn slow to activate

Post by RS23V0G »

Thank you! I've got a vendor that can supply these and has a pigtail also.



Post Reply