LCD Module Inop


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
User avatar
satranger
Posts: 21
Joined: Wed May 13, 2015 8:36 pm
Location: Many, Louisiana
Motorcycle: 1993 GL1500SE

Re: LCD Module Inop

Post by satranger » Tue Dec 05, 2017 5:07 pm



This is the circuit from input to the regulator showing where mine was broke at.


The trace from D2 to C2 is underneath the PCB while the trace from C2 to C3 is on top of the board. The soldered thru lead of C2 completes the connection thru the board, however the top trace was open underneath the base of C2 for some reason.


Last edited by satranger on Tue Dec 05, 2017 5:40 pm, edited 1 time in total.

User avatar
Erdeniz Umman
Posts: 690
Joined: Tue Oct 27, 2015 12:33 am
Location: Ankara Turkey
Motorcycle: 2000 GL1500SE

Re: LCD Module Inop

Post by Erdeniz Umman » Tue Dec 05, 2017 5:25 pm

I see, maybe the cap was touching the trace and by the time the green mask was damaged and shorted the trace causing it to break off.

User avatar
WingAdmin
Site Admin
Posts: 19409
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: LCD Module Inop

Post by WingAdmin » Tue Dec 05, 2017 7:35 pm

Good diagnostic work! It's satisfying to find those kinds of problems and then fix them. I had an old Korg Polysix synthesizer that had an old NiCd battery for the memory that failed and leaked all over the board, eating up a bunch of tiny traces. I did the same kind of fix, but to about 15 different traces, vias and more. It was a triumphant feeling to get it to all power up again.

User avatar
Mooseman
Posts: 392
Joined: Thu Sep 10, 2009 11:10 am
Location: Napa, CA
Motorcycle: 2007 BMW R1200RT 22K
1996 GL1500SE (SOLD) 101k
1986 GL1200A (SOLD) 81K
1985 GL1200A (SOLD) 85K
1986 BMW K75c 29K

Re: LCD Module Inop

Post by Mooseman » Sat Jan 27, 2018 11:50 pm

There is so much on the clock and LCD, I'm not sure which topic to chime in on.
Picked up my Wing 3 1/2 years ago. Constant problem with the LCD going blank along with the clock and or the clock just frozen. Then when it displays again it runs really fast.
Now this happens lots during the winter due to the moisture and cold. Summer if it's a foggy morning again we have issues. Once it's ridden for awhile depending on the day it works itself out.
When this happens and the display is blank, you can turn on the radio and it works.... station unknown.
Key off


key on


Key off


I've heard their is a ground for this assembly. Where is it located on the bike? Thinking maybe corroded.
I did the circuit board cleaning over 3 years ago and it made no difference. Going to remove the unit again and try. When I had it apart last time all the connectors looked good.
When the LCD is blank the Air suspension shows no Pressure reading and won't work the air pump??
Thanks for any input...
Enjoy the ride. They are all good, just some better than others.
Mooseman

User avatar
Erdeniz Umman
Posts: 690
Joined: Tue Oct 27, 2015 12:33 am
Location: Ankara Turkey
Motorcycle: 2000 GL1500SE

Re: LCD Module Inop

Post by Erdeniz Umman » Sun Jan 28, 2018 4:54 am

Maybe, the moisture collected on the circuit board is causing this problem.
You should clean the circuit board and cover it with nail polish or similar products used to protect the circuit boards.

User avatar
Mooseman
Posts: 392
Joined: Thu Sep 10, 2009 11:10 am
Location: Napa, CA
Motorcycle: 2007 BMW R1200RT 22K
1996 GL1500SE (SOLD) 101k
1986 GL1200A (SOLD) 81K
1985 GL1200A (SOLD) 85K
1986 BMW K75c 29K

Re: LCD Module Inop

Post by Mooseman » Sun Jan 28, 2018 1:51 pm

Thank You. Did the cleaning of the circuit board last time and sprayed it with clear lacquer. No change in issues. But you are correct, definite moisture issue...


Enjoy the ride. They are all good, just some better than others.
Mooseman

Post Reply