Radio static after led lights install


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
Post Reply
inanyminet
Posts: 10
Joined: Sat Apr 22, 2017 10:27 pm
Location: Battleboro, NC
Motorcycle: 1995 GL1500 SE

Radio static after led lights install

Post by inanyminet » Mon May 07, 2018 8:26 pm



I have a 1995 1500se that I installed LED lights on and a signal relay for said lights as well as installing a brake flasher. Everything it working as it should yet I noticed two things once riding it....
1. There is static on stations that didn't have static on them prior to install of led lights. You turn key to accs only, no lights just radio, static disappears.
2. The turn signal no longer cancels out as it did prior to install.

Can anyone give me any suggestions to fix these problems, mainly the radio. I can live with the turn signal problem. Thanks



User avatar
Dusty Boots
Posts: 732
Joined: Mon Oct 26, 2009 4:25 pm
Location: Alvinston, SW ON
Motorcycle: 1992 GL1500 Aspencade
2013 Victory Cross Country Tour

Re: Radio static after led lights install

Post by Dusty Boots » Tue May 08, 2018 6:15 am

On my 1500 Wing, I added some LED strips to the rear and those never bothered radio Reception





On my Victory Cross Country Tour, I added a bunch of LED strips as running/turn signals and they never bothered radio reception either!






I noticed radio interference whenever I turned on my added aux LED driving lamps to both my rides.










On the Wing I bought/installed some radio chokes, but they did no good. On my Victory, seeing as it has XM Radio, I subscribed to it as the LEDs don't bother it's reception!

User avatar
WingAdmin
Site Admin
Posts: 19314
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: Radio static after led lights install

Post by WingAdmin » Sun May 13, 2018 5:22 pm

LEDs don't run on 12 volts. So in order to have one that works on a 12 volt system, the manufacturers have to build a driver into each LED. Manufacturers that care, build drivers with good design and filtering. Manufacturers that don't care, go cheap, and build drivers that spray out RFI and render audio systems and radios unusable from interference.

Buy quality LEDs from reputable places instead of Chinese cheapies on eBay, and you generally won't have this problem.

Post Reply