lcd only partially working


Information and questions on GL1500 Goldwings (1988-2000)
Post Reply
moggie1300
Posts: 7
Joined: Thu Feb 13, 2020 5:52 am
Location: Germany
Motorcycle: 1991 GL1500 Anniversary Edition

lcd only partially working

Post by moggie1300 »



Hi all, The time on my lcd works but the radio shows nothing. But the radio is working ok. Any ideas guys. Sounds like a loose connection somewhere,


User avatar
AZgl1800
Posts: 2863
Joined: Thu Oct 30, 2008 2:46 pm
Location: Lake Oologah Indian Territory USA
Motorcycle: 2009 Piaggio MP3 250cc https://imgur.com/foGDjgv

'02 GL1800 lives in Dawsonville, GA now.
My son is going to enjoy it for many years to come.

Re: lcd only partially working

Post by AZgl1800 »

just on the Off Chance the LCD panel connectors are faulty, there is a replacement available

https://www.amazon.com/Electronix-Goldw ... B076FHBJ5C

This is the actual vendor: https://www.taninautoelectronix.com/shop/
~John

2009 Piaggio MP3 250cc

https://i.imgur.com/4SOFPYS.jpg
moggie1300
Posts: 7
Joined: Thu Feb 13, 2020 5:52 am
Location: Germany
Motorcycle: 1991 GL1500 Anniversary Edition

Re: lcd only partially working

Post by moggie1300 »

Thanks friend.This might be the problem as the fault is intermittent :)
User avatar
DenverWinger
Posts: 2006
Joined: Thu Jun 23, 2011 2:20 pm
Location: Denver, CO
Motorcycle: (s)
1980 GL1100 STD Vetter (2005-)
1993 GL1500 Aspencade (2017-)
1983 Trav-Lite Camper (2010-)
Past rides
1972 CL350 (1980-1988) sold
1978 Suzuki GS550 (1985-2005) sold
1977 GL1000 (2002-2006) sold

Re: lcd only partially working

Post by DenverWinger »

There's three connectors on the back of the stereo, one for most of the radio functions (power, speakers, handlebar controls), Another which links the CB radio to the Stereo, and one more small one which feeds LCD display for radio functions. That connector may be loose.
♫ 99 Little Bugs in the Code, ♪
♪ 99 Bugs in the Code. ♫ :(
♫ Take one down, Patch it around, ♪
♫ 127 Little Bugs in the Code. ♫ ♪ :shock:

~Mark
moggie1300
Posts: 7
Joined: Thu Feb 13, 2020 5:52 am
Location: Germany
Motorcycle: 1991 GL1500 Anniversary Edition

Re: lcd only partially working

Post by moggie1300 »

DV, You da man. Had a wiggle ----- perfect! and so is the radio.Thanks all.First GL, still learning. :D :D


Post Reply