Hazard light Issues


Information and questions on GL1500 Goldwings (1988-2000)
Post Reply
jsthomps
Posts: 31
Joined: Thu Apr 23, 2020 11:17 pm
Location: Waterloo, ON, Canada
Motorcycle: 1972 Kawaski H2

Hazard light Issues

Post by jsthomps »



Hi all,
The push button that controls my hazard lights recently got stuck in the "on" position. Using the articles on this site I was able to free up the button using electric contact cleaner. I did have to partially disassembly of the left grip switch module to accomplish this. After reassembly something odd happened. When I push the button in only the left size hazard light activate but if i leave it one for a minute the right side will start to work. Any ideas?
Thanks,
Scott



User avatar
Erdeniz Umman
Posts: 958
Joined: Tue Oct 27, 2015 12:33 am
Location: Ankara Turkey
Motorcycle: 2000 GL1500SE

Re: Hazard light Issues

Post by Erdeniz Umman »

One of the contacts of the switch might be sticking or, not making contact properly.
I would check the switch assy again. Also there should be (if I remember correctly) small springs under the contacts, check them in place and at proper length.

User avatar
Elmobile
Posts: 224
Joined: Sat Aug 22, 2015 8:35 pm
Location: Bridgewater, Nova Scotia, Canada
Motorcycle: 1990 GL1500SE

Re: Hazard light Issues

Post by Elmobile »

Your switch assembly needs a thorough cleaning. This is the link to the post I wrote after cleaning my turn signal switches:
viewtopic.php?f=14&t=56249&p=333965#p333965

I also clean the hazard lights and cruise control switches. They are very similar. I have lots of pictures if it could help. May be I should do a quick write up for them as well but you should find some post already written. Just don't seem to find them right now... :cry:

jsthomps
Posts: 31
Joined: Thu Apr 23, 2020 11:17 pm
Location: Waterloo, ON, Canada
Motorcycle: 1972 Kawaski H2

Re: Hazard light Issues

Post by jsthomps »

Thanks guys ... I through cleaning did the trick!
Scott

User avatar
wezx
Posts: 92
Joined: Mon Jul 16, 2018 2:16 am
Location: Munroe Falls, OH - United States
Motorcycle: 1993 GL1500A

Re: Hazard light Issues

Post by wezx »

My hazards are a little temperamental as well. Left one will light and I have to actuate the switch a bunch of times and then the right comes on. I’ve cleaned it several times but it still acts up. I just actuate the switch a bunch every time I ride it and that keeps it working pretty well. LOL



Post Reply