96se LCD Display


Information and questions on GL1500 Goldwings (1988-2000)
Post Reply
charliep
Posts: 6
Joined: Wed Jan 06, 2010 10:54 pm
Location: sunnyvale, ca
Motorcycle: 1996 GL 1500 SE

96se LCD Display

Post by charliep »



First of all I want to say thanks to all that participate in this group. I have found a lot of help here in my years of owning my Goldwing.
I know this is an old question and I have searched hi and lo on this site and tried everything that was suggested. I have been working on this for months and I am tired. I have both the electrical and shop manual. I have torn into everything except rebuilding the engine and transmission. I am a retired diesel mechanic and know my way around vehicles.

The problem: not all the time, when I shut of the bike an icon, (direction arrow for cassette) will show <, turn the key on then off and the icon, (direction arrow for cassette, opposite) will come on < >. So, pretty much if you have had this problem and I have seen it written in your posts, every time I turn on the key and then off another, (different Icon will show). So after doing this several times any Icon that has to do with radio or cassette show up.

What I have done, I might have forgotten some things :) Pulled the battery terminal off to reset everything, removed the LCD and cleaned and sealed the circuit board, removed and cleaned 3 plugs on underside of player, replaced a couple of relays that was suggested on here. Tapped relays to see if stuck. I actually didn't see any relays in that part of the system.

My suggested repair because I am tired of chasing this and wanted your opinion is removing red/yellow wire to back up memory C1 and installing a switch between located in left pocket on dash. This wire would come from small plug attached to radio. This way when and if it happens I can just hit the switch momentarily and shut of the screen. I know I will lose my stations etc... but a small price to pay.

If you have any other suggestions they would be greatly appreciated!

Charlie



charliep
Posts: 6
Joined: Wed Jan 06, 2010 10:54 pm
Location: sunnyvale, ca
Motorcycle: 1996 GL 1500 SE

Re: 96se LCD Display

Post by charliep »

Hi Folks! Just torn into to bike for the umpteenth time! New discovery! When I remove all connections from radio, 3 plus Antenna wire the same thing shows up like stated in my first message, Icons keep returning when key is turned off, all radio and cassette icons? I removed all relays icons still showed. Remove back up fuse and icons turned off? Something is feeding the LCD screen but why are the radio and cassete icons showing? I guess I will break out the wiring diagram book and look again? Any thoughts???

User avatar
Swagonmaster
Posts: 102
Joined: Sun Apr 16, 2017 3:30 pm
Location: Stokesdale, NC
Motorcycle: 1990 gl1500 SE

Re: 96se LCD Display

Post by Swagonmaster »

I am assuming that the radio works properly which would indicate that the grounds are ok but you might check, everyone knows what a mess poor grounds can be. After that a reboot is in order which I see has already been done, and after that I would be wondering if there is not a problem in the radio itself as everything has been disconnected except the memory wire fuse with no improvement and only after that fuse was pulled did the lights go out. I see there are 3 inline fuses but they come from the back up and accessory fuses so don't kill yourself looking for outside issues I'm not sure that you will find any.
Try to learn from the mistakes of others..... you won't live long enough to make them all yourself!

charliep
Posts: 6
Joined: Wed Jan 06, 2010 10:54 pm
Location: sunnyvale, ca
Motorcycle: 1996 GL 1500 SE

Re: 96se LCD Display

Post by charliep »

Hi Swagonmaster,
Yes, radio works fine. What's weird is that the icons of the radio show up on the LCD screen even with all connections from radio have been disconnected, so I'm thinking there still is power feeding the LCD. I think I may pull that apart again and check the connections again.

User avatar
Swagonmaster
Posts: 102
Joined: Sun Apr 16, 2017 3:30 pm
Location: Stokesdale, NC
Motorcycle: 1990 gl1500 SE

Re: 96se LCD Display

Post by Swagonmaster »

The wiring diagram says that the LCD panel has power from the back up fuse just like the radio, I guess to keep the clock going. Do you have the radio indicators on the display with the key on or only with It off? And is the cb radio off?
Try to learn from the mistakes of others..... you won't live long enough to make them all yourself!

charliep
Posts: 6
Joined: Wed Jan 06, 2010 10:54 pm
Location: sunnyvale, ca
Motorcycle: 1996 GL 1500 SE

Re: 96se LCD Display

Post by charliep »

When key is on, clock, radio works, no icons just station. The CB radio has been on with key not with key off. When key off radio indicators on and after I switch back on then off more indicators show up until all are showing with key off, strange.

User avatar
Charlie1Horse
Posts: 562
Joined: Mon Sep 16, 2013 9:35 pm
Location: Jacksonville, Florida
Motorcycle: 1986 GL1200A Aspencade
1992 GL1500I Interstate

Re: 96se LCD Display

Post by Charlie1Horse »

Did the previous owner, or you, add any new electrical farkles? It sounds like someone has tapped into a wire that is allowing power to 'feed back' through the wiring harness. That would 'power up' some unknown features like you describe. Check out any extra lighting, power outlets or accessory connections to the OEM wiring to make sure of the power source in the harness.
Russell

If I don't do Facebook or Twitter, do I still have to do Social Media Distancing????
Those who say it cannot be done should try not to interrupt those who are doing it.

charliep
Posts: 6
Joined: Wed Jan 06, 2010 10:54 pm
Location: sunnyvale, ca
Motorcycle: 1996 GL 1500 SE

Re: 96se LCD Display

Post by charliep »

Yes, me! I have lights and farkles everywhere. Also it was triked in 2012 but can't remember when this all started. I don't think it was then. It has been several years I have been chasing this on and off. It doesn't happen that often. I just started to get serious because I am ready to sell and don't want to pass the problem on to someone else.
Attachments







charliep
Posts: 6
Joined: Wed Jan 06, 2010 10:54 pm
Location: sunnyvale, ca
Motorcycle: 1996 GL 1500 SE

Re: 96se LCD Display

Post by charliep »

Just removed the dash. Picture attached of what LCD looks like after turning key on and off several times. This is the off position. I unplugged the connectors attached to the dash and displayed shut off. I then checked connector for power, nothing. Plugged everything back in and LCD doesn't respond. Radio works etc... Just no display. Getting hot out, will work on it later. Never had the LCD not show anything.
Attachments





Post Reply